Victor SPX Not Outputing Voltage

We have a Victor SPX that does not appear to be outputting any voltage above 1.8 volts.

This started on our 4 motor drive system (KoP 2 CIMs per side) which has 4 Victor SPXs controlled via CAN. We tried disconnected one motor on each side just to verify that everything was working (not expecting to find any problem) and ending up isolating this Victor. We tried connecting a known working motor to it and connecting a working Victor SPX to the motor that hadn’t worked. The results both pointed to this Victor being bad. The LEDs indicate it is getting the expected signal.

We pulled the Victor out of the robot and connected it to a known working prototyping setup which has a PWM generator controlled with a knob and the Victor still did not work. When we used a volt meter, the most we could get out of it was 1.8 volts but it was VERY inconsistent.

The firmware on all our CAN devices have been updated recently. I don’t have the version in front of me but it was downloaded within the last couple weeks.

What is our next step?

Have you tried restoring the factory defaults?

https://phoenix-documentation.readthedocs.io/en/latest/ch13_MC.html#factory-default-motor-controller

2 Likes

+1 to @Joe_Ross’s post. Did you try running it in reverse? Does it do the same thing? If different, it may be a PWM calibration problem which would be solved by restoring factory defaults.

Another thing to try is connecting the SPX to a different output on your PDP. It isn’t common, but sometimes a channel will get internal problems. If that fixes it, swap to your original breaker on the alternate channel to see if the problem is on the channel or the breaker. With enough variable changes (one at a time), you should be able to determine which piece of hardware is causing your issue.

Yes we tried reverse, same thing.

We have not tried setting it to factory defaults yet. Since the LEDs indicated it was getting the expected signal, would that still possibly fix something?

I’m confirming with a teammate but I’m sure we tried this. And like I said we tried it in the prototyping system which was completely separate.

Do you mean that the LED was on solid green in forward and solid red in reverse? If so, then it would not be a calibration thing, but I would definitely try a factory reset before tossing the SPX or contacting the vendor or CTRE.

Yes I saw it blink indicating slow and fast speeds in both directions. I saw this both on the robot and in the prototyping system.

Then I would try the reset, and if it still doesn’t work decide whether you want to

  • Get vendor/manufacturer support
  • Open the thing and look for loose connections or burned components
  • Damage the thing so badly that you know no one will pull it back out of the trash and put it in your parts bin and toss it

Thank you!
We’ll try the reset visual inspection Monday and then contact CTRE if those don’t help. I’m not sure what vendor it was. Either this year’s KoP or likely one of the last year’s KoP.

I see the CTRE contact info here.

I ended up calling CTRE. They graciously replaced the Victor. I dropped the broken Victor off at FedEx late Tuesday and received the new one Thursday! Thank You CTRE!