Okay, so I’ve isolated my problem. It’s the axis camera.
Whenever I download code that uses the camera, the drivers station says “No robot code”

I’m not getting any error messages at all, it just doesn’t work.

Has anyone found a work around/patch/other solution? I need to do a lot of coding for my camera still…

P.S. does anyone know if WPI/FIRST is fixing this?

Brad at WPI is looking into this.

A work around was explained in the post before yours.

Could anyone go into a bit more detail on how to do this please? Thank you.

Easiest way is to get an account on FirstForge and get the source through svn. Windriver should be able to compile the code for WPILib and you just replace the current executable

I just rebuilt the library and posted it at:

Please give it a try by installing the update and relinking. Let us know if it works.

Sorry for the confusion, I think we hit some limit in the library that’s making the build process somewhat unpredictable.

Downloaded and installed. I rebuilt and downloaded my project, and these three lines still crash my code (“No robot code”):

		AxisCamera &camera = AxisCamera::GetInstance();

Any further suggestions?

attach a console to it so you can watch the boot progress, what error is it giving?

Could you walk me through attaching a console?

couple of ways to do it, one is flip the console out dip switch on the crio and attach to the serial port through a null modem to a computer that is running some console program (terminal.exe works or there is one built into windriver) second is to open up a net console, right click on the remote host in windriver (after connecting to it) then go to target tools and finally target console, a dialog box should pop up just hit ok,

i don’t know how well the target console will work to watch the crio boot though, might connect to late, there is another way to do it but i don’t know it so someone else will have to help you out with that
best of luck

Thanks. Downloaded and installed. It fixes the unresolved problems with the previous version. I’m not having the issues plaid is having. Plaid, perhaps confirm that your crio is running the v20 code by checking the version under the drive station diagnostics tab?

I reinstalled all of the updates, and that helped. The camera code works now, and everything is considerably better.

There is a significant lag time on the camera to the DS display however. Is that normal?

to a point yes, how much lag are you talking?

At its worst roughly from a second and a half to two seconds. In general though about half that.

a half second i believe is the spec for the updated code for everything
try lowering the resolution, making sure the driverstation is not having its processing power strangled by windows power management, connect it via ethernet to the router, remove the live readout graphs from the dashboard if you have not already done so.

other than that i don’t know what to tell you
good luck

All good advice, but from my testing, the charts on the dashboard do not add much load. I saw no difference with or without the charts.

Another thing that will help is to limit the FPS of the camera to what you need rather than telling it to go full 30fps.

Greg McKaskle

we saw, (or thought we saw at least) a significant difference with and with out them, haven’t run any tests though so can’t say for sure

My camera code has gone back to crashing my robot.
Doing this will build and download:

AxisCamera *camera;

and this builds but does the same “no robot code” thing on the drivers station:

AxisCamera &camera = AxisCamera::GetInstance();

I reimaged our crio (v20) and redownloaded the code. No help. I reinstalled workbench update 4.3, remiaged the crio, and redownloaded code. Still nothing.

It was working yesterday morning and it doesn’t work now but I’m convinced it’s a library problem.

try rebuilding (right click project>Rebuild) It often solves some of our problems

I’ve tried that already.

The situation has gotten worse, the Drivers Station LCD now also puts the robot in the same situation… help!