I reinstalled all of the updates, and that helped. The camera code works now, and everything is considerably better.

There is a significant lag time on the camera to the DS display however. Is that normal?

to a point yes, how much lag are you talking?

At its worst roughly from a second and a half to two seconds. In general though about half that.

a half second i believe is the spec for the updated code for everything
try lowering the resolution, making sure the driverstation is not having its processing power strangled by windows power management, connect it via ethernet to the router, remove the live readout graphs from the dashboard if you have not already done so.

other than that i don’t know what to tell you
good luck

All good advice, but from my testing, the charts on the dashboard do not add much load. I saw no difference with or without the charts.

Another thing that will help is to limit the FPS of the camera to what you need rather than telling it to go full 30fps.

Greg McKaskle

we saw, (or thought we saw at least) a significant difference with and with out them, haven’t run any tests though so can’t say for sure

My camera code has gone back to crashing my robot.
Doing this will build and download:

AxisCamera *camera;

and this builds but does the same “no robot code” thing on the drivers station:

AxisCamera &camera = AxisCamera::GetInstance();

I reimaged our crio (v20) and redownloaded the code. No help. I reinstalled workbench update 4.3, remiaged the crio, and redownloaded code. Still nothing.

It was working yesterday morning and it doesn’t work now but I’m convinced it’s a library problem.

try rebuilding (right click project>Rebuild) It often solves some of our problems

I’ve tried that already.

The situation has gotten worse, the Drivers Station LCD now also puts the robot in the same situation… help!

I tried to add the minimum camera code to the simple template to get camera to the dashboard. It builds, but when i download it it doesn’t run because a symbol is missing: AxisCamera::GetInstance();

My includes are
#include “WPILib.h”
#include “Vision/AxisCamera.h”
#include “Vision/HSLImage.h”

My code calls:
AxisCamera &camera = AxisCamera::GetInstance();
HSLImage image;

Are those right?

You you have to call GetImage to get it to display on the dashboard?

Has anybody had any luck with the updated wplib?


Sounds like you have the version 4.2 of WPILib loaded. Load WPILib version 4.3, relink and download the new version.