Vision Co processing on RPi 3 Help

Hi, I am trying to set up vision for my team using a raspberry pi 3 running Raspian jessie. I have tried to follow the steps on the WPI screen-steps site, but I don’t understand how to actually get anything to run. I have very limited knowledge of Linux and the documentation from wpi assumes that you have some. I need to get this working in the next day. Can someone please walk me through exactly what to do to get vision running?

Just an update, I have successfully built OpenCV 3.2.0 on the RPi, and have built the VisionBuildSamples available from and followed the steps from What should I do now? I don’t know how to “run the program” or send the network tables to the RoboRIO.

So, I have found the Jar File and I think this is how I run the program, but how do I know it is working?

Ok, newest problem : Exception in thread “main” java.lang.UnsatisfiedLinkError: no opencv_java310 in java.library.path
at java.lang.ClassLoader.loadLibrary(
at java.lang.Runtime.loadLibrary0(
at java.lang.System.loadLibrary(
at Main.main(

See this thread: