VSCode FRC Deployment Issues


#1

Lately my team has been having some trouble deploying code to the robot. Every time we deploy the code we get an error message like this:

Executing task: gradlew deploy -PteamNumber=1572 -Dorg.gradle.java.home=“C:\Users\Public\frc2019\jdk” <

Task :discoverRoborio
Discovering Target roborio
Using admin@10.15.72.2:22 for target roborio

Task :deployNativeLibsRoborio
Artifact skipped…

Task :deployJreRoborio
-C-> if [[ -f “/usr/local/frc/JRE/bin/java” ]]; then echo OK; else echo MISSING; fi @ /tmp
-[0]-> OK

Artifact skipped…

Task :deployRoborioCommandsRoborio
-C-> sed -i -e ‘s/^StartupDLLs/;StartupDLLs/’ /etc/natinst/share/ni-rt.ini @ /home/lvuser
-[-1]->

Task :deployFrcStaticFileDeployRoborio
-C-> mkdir -p @ /home/lvuser/deploy
-[-1]->

Task :deployFrcJavaRoborio FAILED
-C-> . /etc/profile.d/natinst-path.sh; /usr/local/frc/bin/frcKillRobot.sh -t 2> /dev/null @ /home/lvuser

Task :deployNativeZipRoborio
42 file(s) are up-to-date and were not deployed
-C-> chmod -R 777 “/usr/local/frc/third-party/lib” || true; chown -R lvuser:ni “/usr/local/frc/third-party/lib” @ /usr/local/frc/third-party/lib
-[-1]->
-C-> ldconfig @ /usr/local/frc/third-party/lib

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:deployFrcJavaRoborio’.

A failure occurred while executing jaci.gradle.deploy.artifact.ArtifactDeployWorker
Java heap space

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See https://docs.gradle.org/5.0/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 11s
12 actionable tasks: 8 executed, 4 up-to-date
The terminal process terminated with exit code: 1

At first I thought the problem was with the java heap space message, as we were using grip for vision witch may cause a memory storage issue. After commenting out that code, we still had the same issue. The JRE is up to date, the Roborio is properly imaged. The only thing which may be a problem is with gradle, but the current gradle version si 5.11 not 6.0 as the error suggests, any solutions would be helpful.


#2

I assume you are up to date with the 2019.2.1 WPILib Version and the correct image for RoboRIO?


#3

I’m having the exact same issue. I have everything up to date.


#4

Reflashing the RoboRIO is a next good step, if not maybe your Project configuration and/or file paths.


#5

Please run with --stracktrace and put the output in a gist on this post: http://gist.github.com


#6

Turns out, the Gradle 6.0 issue is nothing. It’s just a heads up of future deprecations. My problem was actually the build.gradle filepath… I spent like, 3 hours trying to figure it out. Oops…


#7

I expected that to be one of the reasons, considering that happened to me and I had to spend a while figuring it out.


#8

Yes my team had the same issue. Go on the first website and get the dev kit or something along those lines and select install VSCODE. It’ll set everything up for you and just open up to your workspace with they VSCODE and it will build.


#9

Can you explain what you fixed? That might help others.


#10

In the build.gradle file, I had the main path listed as frc.robot.team1706.main, when in reality it needed to be frc.team1706.robot.main. It’s really easy to miss. If its throwing an exception saying that it couldn’t find class Main, that’s probably the issue. Your file path might be different.


#11

We are having the same problem and I cannot figure out what it is? How did you fix?


#12

Currently having the same issue, am not seeing a main path in the build.gradle file. We are using C++ We spent the last couple of days making sure we have absolutely everything updated.


#13

What exactly is the error you are getting? The error above was java, so you are definitely not getting the same error.


#15

Executing task: gradlew deploy -PteamNumber=3712 --offline -Dorg.gradle.java.home=“C:\Users\Public\frc2019\jdk” <

Driver Station reported IP: 169.254.156.222

Task :discoverRoborio
Discovering Target roborio
Using admin@169.254.156.222:22 for target roborio

Task :deployNativeLibsRoborio
Artifact skipped…

Task :deployNativeZipRoborio
Artifact skipped…

Task :deployJreRoborio
Artifact skipped…

Task :deployRoborioCommandsRoborio
-C-> sed -i -e ‘s/^StartupDLLs/;StartupDLLs/’ /etc/natinst/share/ni-rt.ini @ /home/lvuser

Task :deployFrcStaticFileDeployRoborio
-C-> mkdir -p @ /home/lvuser/deploy
-[-1]->
1 file(s) are up-to-date and were not deployed

Task :deployFrcCppRoborio FAILED
-C-> . /etc/profile.d/natinst-path.sh; /usr/local/frc/bin/frcKillRobot.sh -t 2> /dev/null @ /home/lvuser
-F-> C:\Users\tasberry\FRCProjects\Wrist Test 1\build\exe\frcUserProgram\release\frcUserProgram -> frcUserProgram @ /home/lvuser

Task :deployFrcCppLibrariesRoborio
22 file(s) are up-to-date and were not deployed
-C-> chmod -R 777 “/usr/local/frc/third-party/lib” || true; chown -R lvuser:ni “/usr/local/frc/third-party/lib” @ /usr/local/frc/third-party/lib
-C-> ldconfig @ /usr/local/frc/third-party/lib
-[-1]->

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:deployFrcCppRoborio’.

A failure occurred while executing jaci.gradle.deploy.artifact.ArtifactDeployWorker
Failure

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 6.0.
Use ‘–warning-mode all’ to show the individual deprecation warnings.
See https://docs.gradle.org/5.0/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 3s
12 actionable tasks: 9 executed, 3 up-to-date
The terminal process terminated with exit code: 1


#16

Interesting fix. Turned everything off and on again.