Ways to speed up code loading process?

Whenever we load our code onto the robot, it takes forever. I understand that this hardware has its limitations, but just to make sure, is there anything I can do when making the hex file in MPLAB to make it load up faster?

To maximize download speed, use a fast computer with a built-in serial port. Most USB-to-serial converters slow down the process a lot.

I was having the same problem, it is taking 17 minutes and is barely above 50%. But if we are not able to get a a laptop with a built in serial , are any other conection converters usefull? The laptop has only a few things but the only other thing that might be usefull is some type of connection that I don’t know its name so I’ll make it on here :slight_smile: somewhat well it looks like a serial port (female) with 3 rows of 5 holes kinda like this if you can under stand it. Ok I’m an idiot so I couldn’t find it :stuck_out_tongue: but This should be enough to figure out what I mean.

its a little more compact…

/ . . . . .
/ . . . . .
/ . . . . . \


That’s a VGA monitor port :wink:

You can try to get a PCMCIA serial port card - but they can be pricey.

I really don’t understand why USB adapters slow things down so much - it’s not like USB is the bottleneck in the system.

The factor which regulates the speed of download is how much the USB adapter is capable of buffering. Make sure your adapter is using the largest possible buffer…

Ok, But…How?
I still don’t allways know to much about this stuff so, I just want to make sure I have everything correct before I mess with something I don’t want/need to.
Also it took 33 min to upload the code to the controller :ahh:

Thanks a lot.
And as for the adaptor that cost a lot how much do they on average cost? do you mean costly for an adaptor or just plan expensive.

Holy. Crap. Do you know any of the specs on the machine you’re using? Pentium 3 or so? There’s usually a little sticker on it somewheres…but that’s beside the point.

To make sure you have the biggest buffer possible (I’m assuming you’re using Windows 2000; not sure if these directions work in XP):

  1. Open the Control Panel – usually Start > Settings > Control Panel

  2. Double-click System.

  3. Click the Hardware tab.

  4. Click the Device Manager button.

  5. Expand the “Ports (COM & LPT)” item. Under it should be a port or two. Pick the one you plan to use with the robot controller (usually the highest number after “COM”) and double-click it to open the properties window. Under one of the tabs (in my case it’s Advanced) there will be an Advanced Port Settings button. Click it, and there should be a window with “FIFO” buffer settings. Make sure the sliders are moved all the way to the right, as this will make sure the buffer is as big as it can be.

That should do it. If it doesn’t speed up, try using another serial cable, another USB-to-serial, or even another computer. I would like to say it’s a driver issue, but it is HARD to find the right driver if you don’t know exactly what you’re doing…and its harder to walk someone through it.

Good luck on this,

PS. If you found this helpful, good rep is always nice :wink:

Cool, Thanks. I’ll try this as soon as I get the laptop running.
And I’ll give some rep to you guys, I just learned how to do it yeasterday…I thought it was some kind of post count for a while :stuck_out_tongue:

Edit: Oh and I’ll get the specs down soon, I thoiught it was a decent laptop at first. 256 ram I know, but thats all I can remember.

Woah, we switched over to the pure serial connection using one of the school’s laptops, and it takes like 30 seconds to complete! That’s awesome, it was taking hours before :eek: Thanks for your help everyone.

Ya, I know I am going to try and get the other laptop if I can but it may be hard, out IT is a jerk somtimes.
But It is a lot faster, I wasn’t able to play with the usb converter but I’ll do it tonight.

Wow… hours! I can’t imagine that. I’m used to it going down in like… 5 seconds. With USB it’s more like 25 sometimes…