Web Game: Deception

You may or may not be familiar with Greg Marra, a member of 177 who posts on here. Greg has developed a new web game for all of our enjoyment, called deception. Leave comments for Greg or help each other figure out what to do. I haven’t quite had the time to finish it yet…it looks like it might be tough.

The Game

pretty interesting, a great display of web skills. Very well done, atleast what i have seen so far, i’ll have to play more when i have time!

Hmm, i’m at the DOS prompt but all the normal file access stuff doesn’t work…

EDIT: Somethings weird… there’s no ACTION reference in that form tag :confused:

I’m assuming the lack of action is due to the fact its not an html document but rather a php scripting that you interact with.

explore the prompt further, some stuff is there, its just weird.

Yeah, somehow he’s hiding it in the source. When I click Display Form Details in the web developer toolbar it spits out
<form id="" name=“cprompt” method="" action="">

It’s using javascript to submit itself. The fact that its a PHP document doesn’t matter, all form data is handled client side (html or javascript) and then processed server side (PHP). There’s no way PHP can detect if I entered something into the forum without some kind of client side code submitting that form.

EDIT: Somethings weird about that AUTOCOMPLETE=“off” code…
EDIT 2: Has anybody gotten past this part yet? Just wanting to know if its at all possible.

i have not gotten past the dos part. the fsck command is taking forever to run,
it has been running since last night…i dont know what happens when its done, but i’ll see soon. did u find /dir?

Yeah I got there
I just ran a fsck and i’m pretty sure your not supposed to just let it run, but it might be a gateway to something

Hmm, did anyone notice when fsck had negative thirty thousands seconds left? :ahh:hehe.

The form is a regular old form that posts information using GET, rather than POST. A bit of javascript autofocuses it when you load, and then hitting enter submits the form. PHP can pull the information out of the GET (it would be able to out of a POST to, but I wasn’t sure how that all worked when I started making this and I like to keep things simple). I’m not sure if it’s using javascript to submit itself, but I think it’s just normal HTML form submission. Autocomplete is off because it destroys the illusion.

And duh fsck takes forever, it’s a PII 200mhz… :stuck_out_tongue:

Here’s my progress so far:

Got to fsck, couldn’t figure out what to do.

Got to oracle, found that nothing could be found due to a corrupted hard drive. Any ideas?

Yeah fsck started up again, I don’t think thats how you fix it…

Hmm…civmsg seems to be something that we have all ignored, but I’m not quite sure what to do with it. I have found a list of handles to log in, but no passwords…I have already tried a bunch of Greg’s inside jokes, but none of them seem to work. Any hints elsewhere where we could grab this password?

There are several things i have found inside the oracle. You can type clue and you get a message about mp3’s. you can type lemonade as the help file suggests and you get a story about lemonade. then there is the paint picture which also relates to the game clue. and did anyone else notice the numa numa program. freaking hillarious, but i dont see why its there other then its funny.

the hard drive is still corrupt after fsck. and yah i dunno about that.
civmsg has some stuff available, there are some commands you can type that do not return the invalid string or whatever message but i dont know how to use them yet, nor have i figured out a password.

I haven’t had time to play with this since last night, but yah, thats some of my notes so far.

Are you guys having fun yet? :smiley:

Yeah…I found the paint picture and numa numa, as well as lemonade, but I didn’t find “clue” yet. I view the paint picture and numa numa as just easter eggs, as Mr. White is our chemistry teacher, but I’ll have to look further to get anything conclusive. And yes Greg, we are having fun (but not as much fun as you are having in Hawaii :mad: )

has anyone found the passwords for civmsg?

Interesting…I found the implication of the clue…spoiler:

It means: application installed: mp3 version 5. The command “mp3” runs an mp3 player.

Implications of this? What do all of these things mean?


By searching the name of every one of his buddies in the address book of civmsg, I was able to find a password for a log (itisraininginalberta). To get to this, just type /logs itisraininginalberta in the civmsg screen. The actual conversation doesn’t seem to have any immediate meaning, but now we know the user’s handle.


We got to his email, from using the /logs itisraininginalberta
(from the log w/ kathryn)
it’s called fastmail
“C:\ fastmail”
interesting stuff in his inbox, all the rest are corrupted
password needed to send email - is not “itisraininginalberta”
does anyone know what the “\r” is after “itisraininginalberta” in the query for allykat218?


any help appreciated!
~Stephanie and friends
Team 1351

Ka-spoiler warnings~
I’m guessing that the password to the email will be one of the last things that you recieve. However, a quick search of canada in the oracle yielded some tourist information. Dont know what its use is just yet, but I’ll find out >.>

Dumped some of the city phrases into log passwords and I got some results, including a program called gallery. nifteh.

Great puzzle, fun fun ^^

reference to spoiler:
city phrases? what city phrases? besides itisraininginalberta? please share!!! where did you get them, the oracle? what did you query? :ahh: thanks!!
/reference to spoiler


I believe the city references are these:
/logs quebecisquitenicethistimeofyear
/logs torontoisapopularattraction

Although there may be more.
References to Fiji in the emails and the IM logs, as well as references to the trueman show, not sure of the significance.