Weird CAN not-connecting talon issue - please help!


#1

Problem: no CAN connection through talons srx. All talons flash alternating red/off or sometimes alternate red/off/orange. Looks like some talons are trying to turn orange but cannot.

Attempted fixes:
All the talons are alternating red/off. As we cut the talons off, some of the remaining talons began to flash orange/red/off but not all the time. We get to a point were the talons are all flashing orange only for a little bit and then they begin to flash red again.

We switched out the rio and the talons began flashing orange! We thought this solved the issue so we began to reattach the talons. All of a sudden the talons went back to flashing orange/red/off. We also thought it might be a rio issue since the rio was initially plugged into the wrong power but since both don’t work I’m not sure.

Any ideas? I don’t know what else to try at this point.


#2

Have you logged into the rio Dashboard to see if it can see the CAN Bus?

If you haven’t, and you can’t see the CAN Bus, make sure you run the Phoenix Lifeboat installer on the roboRIO


#3

the CAN bus isn’t showing up on the dashboard and we’ve run lifeboat on the rio

I’m thinking now that they might be “fault detected” flashing, so I’ll look into that.

another weird thing… when I initially turn on the system, the talons are all flashing red/off but if I wait a while it begins to flash more orange as if it were connected to CAN, but still occasionally gives a red and doesn’t work.


#4

Can you see any other can devices? You need to segment your CAN network, piece by piece, to see what is causing the fault. If you have yellow and green crossed somewhere, it can cause all sorts of havoc. Meter out for continuity from end to end on each green and yellow, and then between green and yellow. You should have continuity from end to end for each color individually, but not between the two colors.


#5

No CAN devices on dashboard and there is conductivity through the green and yellow signals.

We’ve disconnected one talon at a time to see if one may be messing the rest up, but that didn’t help.
If nothing else works, I might check through the individual talons again.


#6

We just ran into this. Make sure lifeboat is installed on the Rio.


#7

Try connecting only the PDP first, and see if you can see that. Make sure you run the newest Phoenix lifeboat downloaded from the CTRE website. The older lifeboat utility won’t do it for this year. The new one actually says Phoenix**** lifeboat on the desktop icon after it is installed to Windows.

I am not an expert on this. My knowledge is quite limited, but this is what worked for us.


#8

What are you using for connecting the CAN wires on the Talon’s together? We have found the CTRE CAN connectors (the 4 pin Weidmuller boards) to be a bit finicky sometimes (even though we use their ferrules and crimper). Unplugging them and re-inserting (sometimes after rotating them 90 degrees) usually does the trick for us.

Regardless of connector, unless your bus is really long (physical length, this worked for us with 14 devices beyond the roboRIO), something like this should work:

  1. Connect the roboRIO to just the first device in your CAN chain (if it’s a Talon, make sure the other wire pair is disconnected).
  2. Verify that the Talon shows blinking orange and is not flashing red (even briefly).
  3. Tug and wiggle the CAN wires to make sure that the Talon doesn’t flash red as you move wires around.

Repeat 1-3 adding 1 device at a time.

If you see flashing red at any point, the connection you just made is likely bad. Check whatever connector you are using to make sure it is crimped well and connected solidly. If you are using the CTRE CAN connectors, try removing the ferrule, rotating and re-inserting. Sometimes we have more luck inserting by pushing the button, even though it shouldn’t be necessary. The good news is once we get them working right, they last the whole season (100s of matches) no problem.


#9

When we get the Off/Red alternating lights, this usually points to our CAN not being connected properly. You might have already seen this table for status lights, but if not:
https://wpilib.screenstepslive.com/s/currentCS/m/cs_hardware/l/144972-status-light-quick-reference/show_image?image_id=5116977


#10

Thank you for all the responses!

The issue was all the talons were trying to connect to ID 0 on the web dashboard. We had to wire them then change their ID one at a time.

Apparently wiring all the talons (more than two at a time) and then trying to ID them makes the CAN freak out.