Weird problem with Talon SRX motor controllers

Hi everyone-

We’re experiencing a really weird problem with the Talon SRX motor controllers. They seem to be supplying power directly to the motor without being enabled.

When we enable the main breaker, the motor that’s connected to the Talon immediately runs to full speed, then seems to trigger a breaker or something, waits for a second, then does it again, repeating the cycle.

It creates two audible clicking noises, and this is a persistent problem across ALL of our Talons, and they are connected to 30A breakers, however the same problem occurs when plugged into 40A breakers.

Our team believes that this is a firmware problem, but we’re wary about running the talons long enough for the radio to start up without damaging them.

Our mentor believes it could be a software issue as it didn’t happen when there was no code on the robot (which could be purely coincidental, since the motor spins full speed before the RIO boots up.)

If anyone has an explanation or a way to fix this, it would be much appreciated.
Thanks,
Michael.

I haven’t heard of any teams having this issue, so you’ll probably want to post more information here, or contact CTRE directly: http://www.ctr-electronics.com/contacts-us

Posting your firmware you’re using will help. The CTRE devs usually ask for a screenshot of Phoenix Tuner.

Alright, but wouldn’t running the Talon for that long damage something…? If not I’ll be good to look at the firmware.

Leaving the talons powered on with your robot is fine, but if your talons are supplying current to the motors when the robot isn’t enabled, that’s a serious problem. Obviously when you run Phoenix Tuner, you should have the motors disconnected from the motor controllers.

It’s also possible that you have the motor controllers wired incorrectly.

How are your motor controllers connected to the RIO?

Through CAN.

All other motor controllers on the bus are working fine (Spark MAXes)

Do you have pictures of your wiring? There’s a possibility you’ve wired it so that the Talons think you’re using PWM and are getting 100% output.

Of just the wiring to the motor controller or the whole system?

I can’t really show the whole system as it’s under a bunch of robot…

Mostly I’m interested in how your power inputs and CAN yellow and green are wired into the system.

image

(I’m aware of the sticky fault, could that possibly cause it? We just assumed that the fault was CAUSED by our problem)

The one thing that stands out to me is that your CAN directly into the roboRIO isn’t twisted. This can lead to EMF noise, especially as you run it over the PDP and power wires.

Is that likely to cause our problem though? I would assume not since everything up and downstream of the talon works flawlessly

It might if the Sparks are somehow getting a signal through the noise and the Talons aren’t, though it does seem unlikely. The other thing to check is if the yellow and green wires are consistent throughout the chain, and not alternating anywhere. I don’t think it’s likely to be firmware if you’re saying it happens with multiple Talons. Have you tried only one Talon on the bus? (just one lead to the RIO and the other to the PDP)

UPDATE: We found the problem. Turns out I wasn’t tracing the CAN bus correctly and some wires somehow got reversed. I honestly don’t know how that works but once reversed it worked fine. Thanks to everyone who tried to help! :+1:

In the future for an issue like this you can unplug the motors from the speed controllers and use the LEDs on the motor controllers to tell if they want to be moving or idle.

The problem with that is that the motor controllers would turn on then immediately trip the breaker, meaning that the lights were visible for only a split second and showed the OK signal.

if no motor is connected, the controller won’t draw much current at all, so no way for the breaker to trip.