weird wireless connection problems

We are using the standard D-Link wireless setup with an Eee PC as the Driver Station and having some strange connection problems. When we try to connect to the robot wirelessly, the connection is unreasonably bad. The lights on the driver station flash green and red about every half second and the results from pinging the router give “unreachable” or times in the thousands. What’s really strange though is that when we connect to the router from a desktop, the connection seems fine. We also tried connection to other devices and the internet with the Eee PC and the connection was fine. Only the connection between the router and the Driver Station seems bad. When we connect the router to the Driver Station with an Ethernet cable the connection is fine and we can run the robot, but obviously this won’t work at the competition. We have another D-Link which we tried yesterday and that seemed to work fine, but today both of our routers have the same problem. We’ve tried multiple fixes such as checking IP addresses, updating firmware, and checking the power, and that all seems fine, but even if they weren’t, it wouldn’t explain why only specifically the connection between the Driver Station and router is messed up. Any help is appreciated.

Actually, that’s how it will work at competition. Wireless from the PC is not used at an event.

Are the bands/frequencies different between the machines that work and those that do not work well?
If the bands differ, then you might have wireless contention from other wireless traffic in the area.
Does your Eee PC show other wireless networks operating?

What mode is the router in?

It might be a problem with the autoscan on the router. We were significantly slowing down our school network and our robot until we turned off autoscan and set the router to a specific channel (in our case we set it to channel 8 because our school was not using it). Now we have no connection problems and we are not crashing our schools network. Has anyone else had this problem?

I’ve seen exactly that problem at a robot demo. The DAP seems not to do a very good job of selecting a clear channel. One team had an unusably bad connection, and a scan of wireless networks showed that their robot had chosen the same WiFi channel as a nearby technology company’s demo system.

We are also having problems connecting to our router. We set it up okay wired, but when attempting to connect to it via wireless it said “windows was unable to connect to wireless network.” We tried changing the ip for the computer to a few different things, and also reset the router and tried again, but it won’t let us connect to it. As we are team 4360, the SSID is 4360. We did not do any security setup; we followed the no-security setup from the manual.

I think I saw that message when the wireless access point had no security enabled but the computer had been configured to connect to it using WPA. Changing the properties of the connection to remove security let it work.

We are having the exact same problem. Is there a firmware update for the router. Could we also use a different router, that thing has been giving us trouble form day 1

I believe we already configured the connection without security on the computer as wells as the router. What doc543 says makes sense, as it seems not everyone is experiencing the problem. Does it have anything to do with us being rookies and getting a rookie kit? Or would veterans get the same router? It also works to use Ethernet through the router; not just straight to the crio.

We fixed it! we did a search on all the wifi routers in the building to see there channel, it turns out the radio was running on the same one as the school was, we set it to manual and on a unused channel and now it is working flawlessly!

We found a program that actually shows you which channels are being used and switched the router to one that was free, but we’re still having problems. The Mac desktops in our room seem to connect just fine, as well as one of our member’s nice laptops. However, our Macbook with Windows 7 Bootcamp on it still has the same really bad connection problem. We’re still baffled at how some computers will connect but others won’t, and we’ve been playing around with all kinds of settings on the router and the computers but nothing seems to have helped so far, not even the channel thing.
We’re going to try using a USB wireless adapter to see if it’s somehow the wireless cards in the laptops we’re using that just aren’t up to the job of connecting reliably to the robot.
I hope we can figure this out soon, although it isn’t hindering our progress much besides eating up time trying to fix it since we can still connect by Ethernet, but if anyone has any other suggestions they would be much appreciated!