When i deploy code to robotrio, it shows a error named "fail to discorver robot rio"

Task :discoverRoborio
Discovering Target roborio
admin @ 10.75.94.2: Connected.
Reason: InvalidImageException
RoboRIO Image invalid! RoboRIO: 2019_v14, allowed: [2019_v12, 2019_v13]
1 other action(s) resolved but not connected.
4 other action(s) failed resolution.
1 other action(s) not started.
Run with --info for more details

Task :discoverRoborio FAILED

FAILURE: Build failed with an exception.

  • What went wrong:
    Execution failed for task ‘:discoverRoborio’.

A failure occurred while executing jaci.gradle.deploy.target.discovery.TargetDiscoveryWorker
Target roborio could not be found at any location! See above for more details.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 5s
6 actionable tasks: 2 executed, 4 up-to-date
Missing Target!

Are you connected to the robot, and is it on?

GradleRIO detected this build failed due to not being able to find “roborio”!
Scroll up in this error log for more information.
The terminal process terminated with exit code: 1

this is what robotrio shows to us. I have tried reboost robotrio, reconnect internet and connect to the robotrio. I also connect robotrio and internet simultaneously, but it cannot work as well. What should I do.

That’s the problem – WPILib requires specific version(s) of image(s) of the roboRIO you deploy code to. So your roboRIO’s image version is FRC_roboRIO_2019_v14, and your code requires it to be versions 2019_v12 or 2019_v13.

However, it seems like you’re using an old version of WPILib. 2020 WPILib should require your roboRIO’s image to be version 2020_v10.
What WPILib version you are using? You can find that at the top of your build.gradle file. The latest version is 2020.2.2.

Also, please note that rule R57 in the manual requires your roboRIO’s version to be FRC_roboRIO_2020_v10 or later, so you have to re-flash it anyway to pass inspection successfully.

can you give some imformation about how to reimage robotrio. I am still a rooky. Thanks

if you installed the 2020 game tools you should have the roborio imaging tool on your computer
you can plug the rio in to your computer with a usb a to b cable and then run that tool and you should be good to go

make sure you also download the 2020 release of wpilib like @dan suggested because you will need it to run any of your code on your rio after reimaging it

thanks

After install FRC game tools, where is located FRC_roborio_2020 image???

Just open the roboRIO Imaging Tool. FRC_roboRIO_2020_v10 should be the only option there (on the right side).

https://docs.wpilib.org/en/latest/docs/getting-started/getting-started-frc-control-system/imaging-your-roborio.html

These official instructions walk you through it. The RoboRIO imaging tool will appear as an app on your computer so you just have to search for it in the bottom left of your computer and follow these instructions.

just solved today, it was a problem with shortcurt in my laptop, I was using old imaging tool not the new one recently installed by frc 2020 game tools.

It is strongly suggested to uninstall all old versions of the gametools prior to installing the new version. This would solve the shortcut issue you had.

Thanks, done.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.