When I try to boot windows, I get an error message

Hey guys,

Maybe you can help me, When I try to boot windows xp home, it gives me an error message:

0x000000CA (0x00000001, 0x89DFE900, 0x89D3F900, 0x0000000)

I can run ubuntu on the same laptop.

thanks,Vivek

Based on what I can find, 0xCA is a Plug and play error…some part of hardware is going bad is my guess…

Hm… I didn’t add any hardware. I did install a software program off the internet (it was open source so not too secure). I’ll try rebooting without any thing plugged in and the wireless turned off.

thanks, Vivek

So at this point, I’m considering wiping the windows partition and reinstalling it. It says it’s due to a faulty driver but I can’t figure out how to delete it. I tried to boot without anything plugged in but still didn’t work so…

Any help would be appreciated.

thanks,Vivek

Go into the BIOS and check for plug and play options; there’s usually something like “Plug and Play OS”. It’s basically deprecated when a modern Windows version is being used with ACPI enabled, but if ACPI is off, it has an effect. So, if the BIOS supports ACPI (it would be have to be a pretty old computer not to support it), it might have something to do with it.

First, I’d try booting with PnP OS off and ACPI on. (This is the configuration that you ought to be using on most modern computers.)

Now, if ACPI was on, and Windows crashes with 0x000000CA, it might have something to do with a bad ACPI driver under Windows. In that case, turn ACPI off and turn PnP OS on. This will revert to the Windows 95-era plug and play autoconfiguration, but ought to still work.

If that doesn’t work, go into the BIOS and disable as many non-essential hardware devices as you can. Try booting. Then re-enable devices a few at a time until you either reproduce the error or it works.

I’m surprised this happened all of a sudden. Are you sure you didn’t plug in or add any hardware or drivers recently?

Also, I don’t know how well this particular version of Linux supports messing with ACPI settings…I can’t make any guarantees that Ubuntu will still boot.

Ok. Thats fine if I can’t use Linux as long as windows works. I have a back up computer.

Right now, all I want to do is get into windows so I can troubleshoot for a faulty driver.

Err, I can’t find PnP in my Bios. I do have a dell laptop. Do laptops use a skimpier versions of BIOS than desktops?

Honestly, it happened a few months ago so I’m not sure what I was doing. I could have plugged something in, but I’ve taken it out by now.

I got the bsod a few times before it became permanent. I could still open windows (and it said the problem was with the memory or something, not a faulty driver.)

Ok, I noticed when I try to boot it in safe mode, the screen stops at a certain file name (it ends in driver/mup ). Is there a way to delete that certain driver with bios or ubuntu?

thanks, Vivek

This may be a stretch, and it certainly is cumbersome, but create a DOS* boot disk (it has a floppy drive, right?), boot to DOS, navigate to the file and delete (better: Rename) it.

Perhaps I am showing my age, and I realize there is an entire generation of users out there who have NEVER even seen a DOS prompt. If this describes you, you can either accept the challenge to learn DOS (think “learning what the dot means” in Luinux), or at least enough to change directories and rename a file, OR find an old guy who uses computers to do it for you.*

Don

** Heh. Like finding a little kid to set the clock in your VCR.

That’s not surprising: many major PC manufacturers use custom BIOS interfaces with few options. I was hoping for something like an Award, AMI or Phoenix BIOS. Then again, if you can’t change it, chances are it’s not set wrongly to begin with, and isn’t the source of the PnP-related bluescreen.

First, what filesystem is on the drive? FAT32 or NTFS? If it’s a FAT32 drive, then Ubuntu will natively support reading and writing it, so you could boot Ubuntu and rename that file to something else. If it’s NTFS, there are Linux drivers capable of writing to an NTFS partition, but as I recall, many aren’t free, and others are very much beta software. You could try loading one of those up, and doing the same, but I wouldn’t recommend that.

If you’d like to do this through Windows, there’s an interface called Recovery Console, accessible from the Windows F8 boot menu (either when you boot from the hard drive, or from a Windows XP CD). The interface is DOS-like, but not quite the same. (I believe typing “help” will give a command list.) To access it, you’ll need to supply the password of the local Administrator account, as they existed when (and if) Recovery Console was installed (I’m not sure if it’s a default option on XP; I suspect not). If it’s not installed locally you could try installing it from the boot CD or bootable floppy set, but I’m not so sure that this will work without a functioning copy of Windows (it’s also installable via the Windows Add/Remove Programs dialog, which is conveniently inaccessible).

If you can get in via Recovery Console, you’ll be able to get file system access with administrative privileges, and rename the offending file so it will be overlooked on startup. Once it’s disabled, then you’ll be able to boot Windows up—it will throw an error that a service or driver failed on startup (because you killed it)—and use the one of the registry editors (regedit.exe or reged32.exe) to remove the references to the driver in order to keep it from starting.

I’ve tried this on Windows 2000, and it works excellently. (I was removing a parallel-IDE bridge driver that I’d installed, and which ended up not working—I think it was a mislabelled Windows 98-era driver, rather than an NT-compatible one.)

Now that I think of it, however, there’s an even better solution to removing the driver once you’ve renamed its file: use Microsoft Sysinternals’ Autoruns to deselect or delete the offending driver from the list (on the Drivers tab). This will painlessly make the same registry change that I referred to above.

There is one big caveat here: first and foremost, don’t do this unless you’re absolutely sure that it’s the right file, and that Windows will boot when it’s not present.

As an alternative, you could also try performing a repair installation. This is also accessed from the computer’s Windows F8 boot menu (either local or from a bootable CD). This will roll back the Windows installation to the version contained on a CD, while (hopefully) leaving program configurations and data intact. If you go this route, it will require reinstallation of service packs and patches to bring it back up to date, and you’ll lose tons of (mostly trivial) configurations. If the driver was a third-party file (search for its name on the Internet to figure out who makes it), the repair installation will delete the registry reference to it, and it will cease to run on startup. If it’s a Windows driver that’s become corrupted, it will replace it with a good copy. But if there’s some conflict between the correct version of the Windows driver and either some hardware or other driver, this will not necessarily solve the problem. (That last case seems unlikely, given the symptoms you’ve described, however.)

Aside: I’m seeing that all of the posts in this thread have occurred at HH:09, instead of the actual post time. Looks like there’s a vBulletin bug…Brandon will be summoned.

A couple of thoughts based on my experiences:

EDIT: Looks like I was beaten to the Repair Installation option but here’s some discreet instructions.

  1. Just because safe mode stops listing drivers doesn’t mean that it’s stopped loading drivers. It continues on loading subsystems in the background. Try it on a working computer. If the last file listed is the same, you’re can be fairly sure that it is not a corrupted file. If they aren’t the same, this is not a sure indicator either, but makes it more likely. Hope they aren’t different though, because corruption at that level can be bad.

All hope is not lost though. Here are a couple of things to try before you go mucking around deleting files:

  1. I seem to gather that you can’t make it into Safe Mode, but if you can try using System Restore

  2. Try doing a repair installation (click on “Method 2” under On This Page). This goes through and replaces key system files (including your low level drivers) and generally tries to revert the system to a known working state, while simultaneously trying to keep the registry and other system information as intact as possible. Best case scenario allows you to continue on afterwords like nothing happened. You may have to install a few of your programs though.

  3. Lastly, if this doesn’t work, you may prefer to reinstall windows without wiping your hard drive. If you have Ubuntu or another updated linux installation or live cd, it may be easier just to copy off your data files and wipe the drive (most modern linux distros have at least a read-only NTFS driver, a good portion have R-W drivers). If you’d prefer to do the copying in windows or you need access to windows for some reason, it is possible to reinstall windows without completely nuking the drive first. Follow the instuctions linked in (3.) except press Enter where it tells you to press R. I believe it will prompt you which file system you want to format the drive with, but select the “Leave the current file system intact” option (or something to that effect it’s been a while).

I’d try at least the first 3 options before you try to fix the problem manually. Hope something of this helps.

–Ryan

Umm… I already formatted my hd and reinstalled windows yesterday. Thanks for the suggestions though. :slight_smile:

My desktop needed cleaning anyway, and I have a lot more free space now. :stuck_out_tongue: I didn’t really have any important files on there since I back them up on my jump drive.

thanks, Vivek

What’s a VCR? :smiley:

Glad you got your computer working. There’s nothing like freshly installed Windows to put a smile on your face… just wait a few months…

Haha, I’m planning on dual booting ubuntu and using windows as little as possible. Windows does have better wireless connectivity though…

-Vivek

Yea, I’m in college and some of the people are running Linux in my programming class. They are having a lot of wireless issues with connecting and staying connected. They carry around an ethernet cable with them everywhere they go. I don’t have many wireless issues on my Mac. For some reason when I connect to the campus wireless network, I always have to put in my password, and I’m not sure how to fix it. It works fine with my personal router, but not with the campus network. It’s not a big deal and it works fine after I enter the password, but if anyone has any recommendations, I’d love to hear it. My other friends with Macs don’t have this issue and they don’t know what they did to keep it from asking them every time.

I’m sure there is a save password feature for the new wirelelss system. I’m not a mac user so I don’t know about the wireless utility on macs.

-Vivek

Yea… not sure, on the Windows side, everything works fine with wireless.

wait, is the security thing set up so that you have to log in on a web page instead of the wireless utility? We have that at the hospital I volunteer at.
You can’t save the password.
-Vivek

No… it’s some the default wireless sign in prompt. Not a website or anything. I cannot investigate it right now. The fan in my mac exploded and seized up, so I had to send it off yesterday.

Did you not have the option to boot from CD and repair the windows installation Vivek? Generally if a file went bad that is vital towards the OS, you can boot from the CD and repair instead of reformatting.