White Paper Discuss: Eclipse for Robotics

Thread created automatically to discuss a document in the White Papers.

Eclipse for Robotics by prograid

I followed your instructuons but when I went to start a new project, the Microchip option was not on the dropdown for Project Type.

Props. now if only i could get eclipse to open without crashing my system. :ahh: I’m using Fedora 4 x86_64. Any ideas?

Please read this!

The plugin posted with the whitepaper will not work. It’ the wrong version.

Use the attached jar file instead. (Just change the zip extension to jar.)


Does anyone know if there is a way for me to edit the whitepaper?

org.eclipse.cdt.mcc18.toolchain_1.2.0.zip (2.86 KB)

org.eclipse.cdt.mcc18.toolchain_1.2.0.zip (2.86 KB)

Even after I downloaded the updated file, it still doesn’t work for me.

I look at the “Plug-in Details” dialog from the About dialog, and the Plug-in IDs go straight from “org.eclipse.cdt.managedbuilder.ui” to “org.eclipse.cdt.refactoring”.

Extracting it into a folder doesn’t help. (The dir has since been removed.)

Version: 3.1.0
Build id: I20050627-1435

The only error in the error log I can find is this:

!ENTRY org.eclipse.update.configurator 2005-11-30 17:45:06.320
!MESSAGE Could not install bundle plugins/org.eclipse.cdt.mcc18.toolchain_1.2.0/   Bundle "org.eclipse.cdt.mcc18.toolchain" version "1.2.0" has already been installed from: update@plugins/org.eclipse.cdt.mcc18.toolchain_1.2.0.jar

In the configuration details, I see:

org.eclipse.cdt.mcc18.toolchain (1.2.0) "Microchip C18 Compiler Tool Suite Managed Make Extension" [Installed]

  file:/d:/Program Files/Eclipse/plugins/org.eclipse.cdt.mcc18.toolchain_1.2.0.jar

What the heck is going on? :confused:

Very odd.
I’ve never actually read the error messages. (It always worked for me, so I’m not sure what they mean.)
Try starting eclipse with the option -clean.
Are you sure that you’re CDT installation worked?
Becauser there should be plugins like org.eclipse.cdt.core, etc.
In other words can you create a GNU C/C++ Project?
If not, then delete all the files in the plugin directory that have org.eclipse.cdt.*
and anything related to CDT in the features directory.

Then download CDT from CDT’s download site. An unzip the file and copy the appropriate files to your plugin and features directory. Then start eclipse with the clean option again.

If this doesn’t work I’ll try posting this problem in CDT’s newsgroup.

That did it. Thank you.

Ok, new bug.

You don’t use the enviroment variable MCC_INCLUDE. You appear to hard-code C:/mcc18/h. (A false assumption; I have mine installed to D:\mcc18\h)

I also can’t find an option to change it.

Thank you for telling me that, I didn’t know about MCC_INCLUDE, but you still can change it. Go to project properties C/C++ Build Settings. Look at Compilation Information, under the C18 Compiler heading of the Tool Settings tab, Change the Include path from C:\mcc18\h to D:\mcc18\h.

I’ve now discovered something else.

If you use the MinGW make, it will mung the command, so that it calls:

mplink ..\18F8520user.lkr **w:/ m:/** FRCMapfile.map D:/msys/1.0/odefault_2005.hex ./ifi_startup.o ./ifi_utilities.o ./main.o ./printf_lib.o ./user_SerialDrv.o ./user_routines.o ./user_routines_fast.o /lD:/mcc18/lib ..\FRC_Library.lib

Cygwin’s make does not exhibit this behavior.

Sorry, about taking so long to reply.
It could be because you have both make programs installed.
I’m using MinGW’s make and I have the following output (using Eclipse 3.1.1 and CDT 3.0.1)

mplink "..\18F8520user.lkr" /a INHX32 /w /m FRCMapfile.map /oRoboticsCode.hex  ./254_arm.o ./254_drive.o ./254_encoder.o ./254_gyro.o ./254_interrupts.o ./254_timers.o ./254_utilities.o ./eeprom.o ./ifi_startup.o ./ifi_utilities.o ./main.o ./user_SerialDrv.o ./user_camera.o ./user_routines.o ./user_routines_fast.o   /l"C:\mcc18\lib" "..\FRC_Library.lib"

I actually had to grab that by some script hooks (so it would show me the command).

The output is something like “invalid input: m:”. It still prints the command it’s supposed to send. It’s munging on make’s part. (I looked at the generated file. The command was correct.)

Steve, Have you had any luck fixing this? I’ve tried the same thing with an Ubuntu linux distro and I have the same problem.


run eclipse with the -clean option, then try it.

no luck…

I am able to create a GNU c/c++ project, and GNU, GNU on windows and GNU on MAC OS X are available, but no microchip reference

btw, when I go to put the .jar file in a plugins directory, I find

so which one? I copied the .jar to /usr/share/eclipse/plugins and soft-linked it elsewhere

any ideas?


OK…re-read Using Eclipse thread and figured it out…

Hello all

I have been using MPLAB for a while, and was already using eclipse, so the chance to junk MPLAB was eagerly taken!

I have Windows XP, with eclipse 3.1.1 with CDT_SDK 3.0.1. I installed minGW (via the MSYS install), set up my paths and off we went.

I have had a number of problems, some soleved, some went away, one remaining, as below

  1. Flags for error level is incorrect -nw=x - should be -w=x. Sorted by editing the .xml file (after unzipping from .jar file)
  2. I wanted to specify the large memory model, so again modified the xml.
  3. The del /f command doesn’t work - it is built in in win32 not a stand alone command. The cleanCommand doesn’t seem to be acted upon, so (temporarily) I copied minGW rm.exe to del.exe and that works. Makes no difference, as eclipse clears the build directory prior to doing a make clean (via project/clean), but it works.
  4. The minGW make seems to do something odd - the linker tries to read the a:/ drive and can’t, giving an error. Again temporarily I tried a make from gnuWIN, and that seems to do what is expected.
  5. The default library FRC_Library.lib which I don’t use would not go away when deleted from the project properties so I removed that from the xml file as well. Also the unneeded -D_FRC_BOARD flag for the compiler.

I had some problems which have gone away - principally the linker looking in the wrong place for the object files. The compiler was putting them in the build directory, the linker looked in the source directory. This has gone away - I didn’t do anything obvious.

  1. Finally the one thats left (may be a feature!). There is no dependency checking done. If I modify a header file, the relevant object are not rebuild. Is this expected?

I will post my modified xml file if its of interest, when I have had a bit longer to go over it.

I welcome any comments on any aspect of the above

Regards Mike Newsome

Most of the mods you’ve described I’ve also done. (The only thing missing is ASM compilation.) Basically, I’ve added complete compilation options. (Within limits of the system.) (I’ve also made a generic makefile. It compiles all your c & asm files and links them together. Not quite ready to release it, though.)

As far as Make goes, that’s the nature of the MinGW make. It interprets /w et al as w:. I’m pretty sure that the linker will accept -w style flags, but I know for sure mpasm won’t. Cygwin won’t do this, but interprets \ as an escape character. :frowning:

I wasn’t able to fine Make on the gnuWin website; maybe you could link us?

I found this collection http://unxutils.sourceforge.net/ which seems to do everything I wanted.

Have you got the proper dependencies working? That would be nice!

Regards Mike N