Wierd error (With edu bot ...

Okay i am using the Edu robot controller when i program and run it it seems the program is not looping or something the wheels keep moving forever and there is no Message like IFI user process initialized…i tried printf in stuff and nothing shows up in the IFI COM window

any help appreciated

Are you using the headers made for the EDU? there is a diference.
In txdata (defined in main.c), set the user_byteX to an output. It shows up in dashboard. (txdata.user_byte3 = 123)

Are you using a custom code or the default code? If you are using a custom code then you probably have an initialization problem (please post some code). Try to load the EDU default code. If you can’t get the default code working then talk to Innovation First, because it is most likely a hardware failure.

Was there a point at which it did work that you can back off to, or is this your first cut at testing some of your FRC code on the EDU?

Are you trying to run all your FRC code or just selected functions like autonomous?

Any warning lights on the EDU controller?

Using the proper EDU compiler flags, e.g., not _FRC_BOARD?

We were running the WRRF code (Its the western regional robotics forums or something like that…) but we switched to FRC … now it works