Wind River Installation

I have been having issues installing Wind River. I re-installed Wind River this year and followed the instructions here. When I open Wind River, I am unable to set up a VxWorks Target or download Examples. There is also no FIRST Menu so I can’t deploy or undeploy the program (I assume).

Error when I try to open an example
What I see when I try to setup a target

Here’s what I have tried so far:

  • Re-installing several times
  • Installing the software on the NI CD
  • Installing the updates from firstforge

If anyone has advice for what I can try to do, it would be appreciated. No one else has Wind River installed on their computers. We have it on the Classmate, but I would rather not develop off of it.

Did you uninstall the previous version on your laptop, or did you install over it? Also I want to double check, the instructions you followed on the install; did you scroll down to the existing installations section or did you start at the top?


I went down to Existing Installations because I had a copy (that worked ::ouch::slight_smile: from last year. I first tried installing over it. I have since uninstalled and installed a new copy.

I was able to find a solution, but it is not elegant. I copied all the files from the classmate with the working copy of Wind River to my computer. When I tried running things there were errors about a corrupted install, so I re-installed a couple of the VxWorks from the new CD.

I do notice that the FIRST downloader disappears when I run the update from firstforge. I have a backup of the .jar file. When I copy it back to the folder, the downloader appears again.

Very strange stuff, but it looks like it is working now.

I’ve have spent dozens of hours dealing with installing and setting up Windriver, and have found the following to be the best process to follow:

  1. Turn off antivirus - THIS IS IMPORTANT!
  2. Uninstall all previous versions of WR
  3. Delete any remaining WR files AND the Windriver directory
  4. Install both WR disks, regardless of 32/64 bit systems. MAKE SURE TO UNCHECK THE TWO BOXES AT THE END OF DISK 1.
  5. Run the updates for FRC. There’s a new one out for mid-season.

Hope this helps!

I think I did leave my antivirus on. I’ll be sure to remember that next time. Thanks.

I finally figured out the source of this error. In the command prompt, the path variable did not contain C:\Windows\System32. This prevented the updater from replacing all the files it deleted, since it depends on xcopy, a program in that folder. Once it was fixed, everything worked as it should.