WindRiver Errors

I compiled the layout given here:

#include "WPILib.h"
class RobotDemo : public SimpleRobot 
		// put initialization code here 
	void Autonomous(void) 
		// put autonomous code here 
	void OperatorControl(void)
	 	// put operator control code here 

and I am getting the following error:

C:\DOCUME~1\LCHS\LOCALS~1\Temp\ gcc: command not found
C:\WindRiver\workbench-3.0\x86-win32\bin\make.exe: *** [09_2429_v1/Debug/Objects/09_2429_v1/h/tool/common/defs.o] Error 127
Build Failed in Project '09_2429_v1' (Process Exit Value was 2):   2009-01-13 16:31:42   (Elapsed Time: 00:03)

What do I need to do to fix this, I dragged in the h folder and lib from the target folder, but its still not working, any suggestions?

We are really stuck can no one help? :confused:

gcc is the GNU C Compiler.

It appears that WindRiver can’t find the compiler that it is set to use. If you poke around in the compiler settings, maybe you can find a place to set a path to the compiler. If you don’t know where the compiler is, you can do a search (winKey + f) for gcc to try and find it.

gcc is the GNU compiler used by the make process to compile your code. WindRiver obviously can’t find it to run it. Make sure that gcc.exe exists on your system, then check your path statement in Windows. It should include the location of gcc.

This all should have been handled by the WindRiver installation. I would hate for you to resort to a re-install but if your installation got hosed you may need to do just that. You’ll save time in the long run.

Okay for some reason I am now having trouble making a project, are there directions on making a project that isl inked to the compiler, because the read me files in the docs folder under the WindRiver folder are not helpful.

also once the project is made how do you make a file in it, we are really confused, so any and all info on making this initial project, files ect… would be extremely helpful! :smiley:

Have you tried

File -> New -> Example

Then vxworks Downloadable kernel module sample project

Then select a template that starts with FRC?

Hi I am having the same problem as ExarKun666. I even tried re-installing and I still get that error. I don’t know what to do now.:frowning: