Windriver: include paths and new build targets

I’m having trouble using WindRiver. I want to start figuring out how to implement my ideas for the code but I keep getting hung up on setting up my project in WindRiver.

So far:
I made a new project once and I tried to include WPI.h. I added the right include path but the compiler gave an error saying it couldn’t open WPI.h.
At that point I just decided to use the project DefaultRobot and edit the .cpp file there.

But with DefaultRobot I could never find the .out file. I tried adding new build targets but none showed up anywhere at all (I searched the whole computer).

So now I’m just editing a project that I know had all the right include files and a build target already. That works fine for now I guess, but explanations would still be nice.

If memory serves me correctly, this is what I did:

  1. Create a new Project using File->New->VxWorks Downloadable Kernel Module.
  2. Enter a name for the project and select Create project in workspace (default). Click Next a couple times, using defaults, until reaching Build Specs.
  3. Enable PPC603gnu, uncheck the other options. Click Finish.
  4. In the Project Explorer, right-click on the new project and select Properties.
  5. Select Build Properties, then the Build Paths tab. Click Add and and enter a new include path: $(WIND_BASE)/target/h/WPIlib
  6. Select the Libraries tab. Click Add and enter $(WIND_BASE)/target/lib/WPILib.a.
  7. Add your own files to the project, and edit as normal.

The .out file should be located at $(WIND_BASE)\workspace<ProjectName>\PPC603gnu<ProjectName>\Debug<ProjectName>.out. The downloader should be configured to use this file. That can be done in Window->Preferences->FIRST Downloader.

Also, note that you need to include WPILib.h, not WPI.h. I’m not sure if this was just a mistake in your post or not.

Thanks. I haven’t tried that yet but I’ll do that during tomorrow’s team meeting.

Also, yeah, that was a typo in my post. My include statement was for WPILib.h, not WPI.h