Windriver Installation Error

So I would have to admit we pretty much made a mistake during our install, we installed the Workbench 3.0.1 over the old installation because we could not find the uninstall tool. Now we also opened the workbench before installing the second disc, like it said not to, essentially we rushed into the installation which was out fault. However, after realizing we made this mistake, we uninstalled windriver, deleted the directory (naturally we backed up the code), however when I run the first installation disc, it keeps failing at the install and the error says:

InstallShield process can’t start due to corrupt install image.

Does this mean we will need to borrow an installation disc from another team or is there anything we can do to solve this issue? Thank you !

NVM Got it working apparently all I needed to do was install the second disk again, now installing then NI Disc should create the FIRST menu correct?

The FRC menu gets installed by the FRC Wind River Update available online:

I had a similar problem, except that installing disc 2 didn’t work for me like it did with the OP. Just in case anyone is still having problems, I eventually found out that it worked if I deleted C:\WindRiver AND the much harder to find C:\Program Files (x86)\Common Files\InstallShield\Universal\WindRiver. I then re-installed per instructions and everything was fine.

Wow - thanks for finding this deep directory solution. I had this problem over the weekend and after many hours of hacking away at it and playing every trick I knew to play…I wound up taking that laptop back to factory settings in order to get a good installation. I gotta say - it’s pretty rediculous when a software package cannot be installed from the installer. Period.


Wow also, thanks stiltjack, I have been struggling for weeks trying to install on a different computer. Deleting the fle in the programs(x86) directory fixed the issue.

Now I can confirm if the issue with RoboRealm is with the laptop we have been using.

Thanks a bunch,