Wireless Bridge Problems

So far we have been running our robot just fine in tethered mode, but when we tried switching over to wireless we ran into some problems. When trying to locate the wireless bridge on our pc using the veteran instructions provided to us by FIRST we were unable to locate the bridge. The manual gives us the IP address 192.168.1.1 however when we type this into a browser as instructed the page cannot be found. We are sure it is the bridge that is the problem. We have tried switching the eithernet cables, we checked the router’s IP address to make sure that it was working correctly, we’ve done just about everything we can think of. can someone please help!

Is your wireless bridge still setup from last season?
If so then the WPA security might still be set from competition and the SSID may be incorrect.

Try browsing to IP:

  • 10.30.55.1
    If you’ve reset the bridge then try:

*]192.168.1.250

P.S. Make sure your PC IP is compatible with each of those addresses, e.g., 10.30.55.6 or 192.168.1.6

thanks a bunch! we got the wireless working now so that when the driver’s station is running it shows that it is communicating with the robot, however, when we tried sending code to the cRIO as a startup VI (labview) the driver’s station says that there is no code, what could be the problem?

It’s probably how you are sending the code and then running the Driver Station.
If you download the code temporarily (“Run”) they can cancel each other out.
How are you downloading your test code?
Here are two general ways to do it.

Temporary code download:

  • Exit out of the Driver account on the Classmate

  • In the Developer account use the “Run Continuously” button only on the main vi (not any sub vi’s).

  • Start the Driver Station app. in the Developer account (Windows Start -> All Programs -> FRC Driver Station)

  • The Robot Code light should work
    Permanent code download:

  • In the LabVIEW Project Explorer window on the Developer account, right-click on the file listed under “Build Specifications”

  • “Build”, then when that’s done

  • “Run as startup”
    *]Then you can switch back to the Driver account, or start the Driver Station in the Developer account

i sent the code from a different laptop as a startup program using build specifications, and left the netbook in the driver station account, (similar to how you would have treated the robot last year with the blue box and the computer you would use for programming)

That sounds good then. It is pretty much as you would have done last year.

At the end of the “Run as startup” did LabVIEW ask you about rebooting the cRIO? The code won’t take affect until the cRIO is restarted.

Was this working before you had the wireless problems earlier?

i ran it as a startup and labview asked me about rebooting the cRIO and i did, the robot worked fine in tethered mode, i had no problems, but now when i send the program as a startup it will run on the robot fine, but when i turn the power off the signals on the driver station show that i’m getting a signal from the bridge and the router but, the robot light remains red, and at the same time off to the left it says there is no communication with the robot nor any robot code, i dont know how to approach this problem, any suggestions?

I figured you meant turned it back on :slight_smile:

I do have one thing for you to try.
After you cycle the power to the cRIO and after the Digital Sidecar Robot Status LED begins to blink…

There is a little, tiny black reset button on the cRIO near the power connector.
Push that with the point of a pen or anything pointy.
That will reset just the cRIO and not the robot’s wireless bridge.

See if, after that, the Driver Station status lights get better. (after the Robot Status LED starts to blink, yet again…)

P.S. You can try the reverse too,
i.e.,leave the cRIO on, then cycle the power on the wireless bridge by pulling the power cable out and reinserting it.