Wireless Communication Setup (Home & Competition)


I am helping a FRC team(for a local event) to setup their robot. I am having problems with setting up access point for wireless communication and hoping to get some help to solve them.

I know I should follow http://wpilib.screenstepslive.com/s/4485/m/13503/l/144986-programming-your-radio-for-home-use link to setup radio for home usage. My problem is that when I connect access point to my pc(Wireless disabled, AP is in AP 2.4Ghz mode), I get an ethernet connection that says No network access. And bridge configuration utility does not list this network interface in the start up so I can not configure it.

I tried to follow some forum threads, but no luck so far.

As far as I understand, I should configure access point that way, then connect access point to the robot using ethernet and connect to the access point from pc through wi-fi, am I right?

My other question is, what will happen at the event? Do I keep access point on to the robot? Because guides state that it is for home usage only.

Sorry if my questions are too basic, I just did not have much time to start with, since competition is too close.


One thing that I can recommend is to do a complete reset of the router. I have had the same problem with getting the router setup and that normally does the trick.

When you are at the competition, the router will be reconfigured to the competition specifications using the kiosk at the competition. You will still use the same router.

Thank you for the answers!

Unfortunately I have tried resetting router a few times(pressing the reset button for 10-15 seconds) and still kept having the same problem.

I am using a windows 7 laptop if that matters.(I have tried connecting router to the different computers and got No Network Access error for the ethernet connection in each of them)

On the computer that you are using, try running the troubleshooting wizard by right clicking on the network indicator in the task bar, and selecting the troubleshooting option. See if that turns anything interesting up.

Try the following procedure, I’ve never actually used the bridge configuration utility, I prefer to set it up manualy (and show students how to do so) because it both works better, and give a better understanding of how the network works.

  1. Start with a completely clean/reset router. (ie Do a reset using a paperclip into the button near the power connector), and connect to PC via Ethernet.
  2. Set computer ethernet IP to*
  3. Using a browser, log into DLink ( Go to network settings and change IP to 10.TE.AM.1 After saving, the DLink will log you out.
  4. Set computer IP to 10.TE.AM.40*.
  5. Log back into DLink, go to advanced settings -> DHCP settings. Set the IP range to be 10.TE.AM.100 - 199*, netmask, default gateway 10.TE.AM.1
  6. Go back to wireless setup (ensure you go to manual, not automatic) and set the SSID to TEAM*, etc.
  7. After you disconnect your computer, make sure you go change the PC IP settings back to DHCP

Hopefully that will work for you.

  • all these need to be in a specific range to work, and can take on other values. I just picked a number that I know works.

As general info, a big thing to watch out for is a conflict between static and DHCP IP addresses. If, on one network, you have the DLink giving out ips in the range of 10.TE.AM.100-199, you CAN NOT set a static IP on your computer in that range (so 10.TE.AM.123 would be illegal) however, IPs out of that range (and on the same subnet) are allowed (for example, the cRIO at 10.TE.AM.2 would function fine with a DHCP server giving out 10.TE.AM.100-199)

Secondly, do all this with the roboRIO off. From the roboRIO manual:

The first time you power up the chassis, it attempts to initiate a DHCP network connection. If the chassis is unable to initiate a DHCP connection, it connects to the network with a link-local IP address with the form 169.254.x.x .

I’m not sure if the roboRIO keeps the IP, or for how many power cycles. Nonetheless I’ve made sure that I only power on a roboRIO with a network which has DHCP running, and haven’t had any problems.

Normal operation at home would be to connect wirelessly for ease of driving freely. It can be handy to have the DLink serve DHCP for both the roboRIO and the PC, but even without that the DLink will usually work with just about any settings, even the default factory settings.

Try this for wireless robot operation:

  • On your PC, wireless needs to be Enabled and set to DHCP.
  • The Ethernet adapter can be Disabled to simplify this testing or at least set to DHCP if you want to tether directly to the robot DLink.
  • On the PC there is a list of AP’s the PC wireless has found. Do you see your team number listed as one of the available networks?
  • Does your PC label any other network access point as “Connected”? If so then you need to Disconnect from it and Connect to your team number AP.
  • After Connecting your PC to your team number network, the message should be “No Internet Access” or “Limited network access.” That would be normal, since the robot’s AP isn’t normally connected to the Internet.
    *]Start the Driver Station app and on the Diagnostics tab (second one down on the left) you will see a list under “Pinging…” See what gets a green light in that list. It should be green for Bridge and Robot.

I want to thank all of you for the answers. Thanks to you I was able to setup wireless communication successfully today.

Troubleshoot suggested me to reset the access point, but resetting did not help.

I followed your suggestions and it worked! :slight_smile:

@Mark McLeod
After following instructions at the previous post, I was able to connect AP(which is named as my team number)