Wireless Connection issues

Hello,
We are experiencing issues with our radio running wireless, I am unable to connect or find the network.It was working previously just fine.I am able to see the network from my phone and another team’s laptop.I have tried a few things; resetting the radio, pinging the IP, checking windows firewall, re-imaging the roboRIO, switching radios,checking proxy settings, and all have left me empty handed. If anyone has any ideas they would be greatly appreciated.

Our robot is not working tethered either,we have had only luck with printer cables.
Thank you,
280

Have you used the team radio configuration tool to set the radio configuration back to what is used at your shop?

Are you tethering with Ethernet to the radio or to the roborio

We have used the configuration tool to restore the radio back to its shop settings,sadly we haven’t found it to fix our problem.We are tethering directly to the roborio.

Did you run the configuration utility in 5 GHz AP mode, and the laptop doesn’t have a 5 GHz wifi card?

When you tether to the radio over ethernet, do you see a connection on the Adapter Settings page? If so, can you ping the radio (10.TE.AM.1)? Can you go to the radio config webpage (also 10.TE.AM.1)?

We are experiencing this issue on various laptops throughout our shop with varying hardware.We have tried running it on 2.4 GHz as well,however the problem was still there.

Just tried to tether to the radio using an ethernet cable,I could see the connection on the adapter settings page,and it was able to ping successfully.I am not able to go on the radio configuration webpage though.

It is possible the firmware on the radio is outdated. Try updating it with the Tools menu on the configuration utility.

Many possibilities could be wrong: 1. Ethernet cable could be broken (from RoboRIO to radio) 2. Radio port could be broken 3. (Worst Case Scenario) Ethernet port on the RoboRIO broken

If you can ping the radio IP, it’s not a hardware problem. I’ll second reflashing the radio firmware.

If that doesn’t work change the ethernet cable from the RoboRio to the AP just to see if that changes anything.

If you have one of the old DAB1522 or w/e radios, try using it instead just for practice and demo runs. I actually prefer them, they seem to be less finicky and a bit more robust than the OM5P radios.

Other things that might help:

  • Once the robot is booted, hit “RESET” on the Rio. Sometimes this will bring the interface up properly
  • Make sure the Rio is plugged into the AF port on the radio, and not the PoE port. We had some random problems with this one last year.

Also note that tethering directly to the Rio doesn’t usually work off the bat because your drive computer won’t get an IP without the radio acting as a DHCP server (when in non-comp mode) and will drop to default values.

If you tether directly to the Rio, you’ll want to set a static IP on your drive computer of 10.TE.AM.xxx, I usually set the last one to 200. Subnet 255.255.255.0, leave gateway blank, now reconnect/reboot/do whatever, it should come up.