Wireless Connection Problem

Hi gang, I’ve reseached this question but not found any answers, I hope someone can help.

Our wireless benchtop test has never passed. On previous Cheif Delphi advice, I went ahead and re-imaged the cRIO and DS with the latest loads (steps 5.1, 5.2, 5.3). All that went relativly smoothly. I also went through the wireless adapter configuration in step 5.6. But when I get to step 11 of 5.6.2 where you disconnect the DS router (WRT610N) from the Robot bridge (WGA600N), I get nothing. I’ve read in other posts were the laptop may have automatically turned on encryption which needs to be disabled. I’ve reconnected the two and ensured the security items are all off or disabled. I also noted that in step 8 c of 5.6.2, the words say set the DHCP field to start at 10, put the associated picture shows 1. Not sure which is correct but neither helped my situation. Also, I can ping the two devices when they are wired together, but when I disconnect the robot bridge, the pings to it go un-answered. Could our bridge be bad? Any ideas?

From my eperience with networks (9+ years), the bridge will be unpingable when connecting from the wireless side, this is due to the fact that it is transparent to all but the wired side when in bridge mode. You should be able to ping the crio though over the wireless connection. I was successful in performing this yesterday.:smiley: Basically the bridge is acting as a media converter, converting a wired transmission media to a wireless transmission media, and vice versa.

I was able to ping the cRIO while wired, but wireless gives me nothing.

It sounds like the bridge is not connecting to the router over wireless. It could be security, wireless band, or something else. Sending you a PM to help diagnose further.

Team 2607 Software Mentor

Many old laptops do not support 802.11n , you can switch the router/bridge to 802.11g/b/n mixed to temporarily test your system.

We had this problem as well.

Sorry Andrew,
I’m not very network savy. Are you saying to “switch the router/bridge to 802.11g/b/n mixed” and then use the lap top’s wireless to see if they can be “seen” by it? You mentioned your team had a similar problem - how did you remedy it? Thanks for your help!

We had the same problem and it turns out security was enabled.

My laptop did not operate over 802.11n wireless protocol only over 802.11b or 802.11g (this is common for most old laptops).

The instructions state that the router and the game adapter must be set to 802.11n only. However I decided to modify the router and game adapter to use 802.11b/g mixed instead.

After I made that change my laptop connected properly.

Let me know if you have any more questions.

i cannot get a signal either. is it frc legal to have the wireless setup to anything other than 802.11n?

We were a beta test team. We had this problem with the beta equipment and with our FIRST equipment. The simple answer is after you set up your network ip addresses power cycle everything in order. I don’t know why but sometimes the IP address doesn’t take until you power cycle the router and bridge.

This is the power cycle order
1 Router
2 Driver station (wait until it boots up) then go to step 3
3 cRIO
4 power up the wireless bridge

If powercycling doesn’t work it is far quicker to reset the router and bridge back to factory default and start over rather than to try to figure out where you went awry. When you reset to factory default use the included disks do not do it from the web.

Our team has similar issues with the driver station getting stuck in No-Comm mode. We have the router and the driver station on the same power strip.
So we do a similar power cycle if stuck in the No-Comm loop.

1 Router/DS (power strip)
2 cRIO / wireless bridge (main battery switch)

Most of the time the communication works slowly but surely. The No-comm failures are small but it could be annoying if teams have to wait a minute for the system to startup and then possibly have to power cycle.

We are using Update 2.0 default code with 802.11b/g (because we don’t have N laptops )

Are you intentionally trying to use your laptop’s WiFi radio? Why not disable your laptop’s radio and hard-connect to the DS’s router? That is, I believe, the technique that FIRST intended.

Considering the control system’s configuration, maybe there is some difficulty associated with having 3 wireless radios trying to share (eg the system is intended to be ad hoc and not point-to-multipoint).


That’s what i thought. That teams should be connecting through the DS router not the laptops wireless internet. Anyways we are having the same problem. I do everything in order that the manual says, but when it says to connect to the bridge(the robot adapter) wirelessly it doesn’t seem to work. Also recently we encountered a new problem which is the wireless light on the bridge keeps blinking. Is that suppose to happen. I have tried resetting it from within(by doing the restore to factory settings) and also held the rest button for 30 sec. Redid the whole process and still no luck with connecting to the bridge through wireless or to stop the blinking light.

  • The bridge does work when it is wired but not through the DS wireless router. I also tried pinging it and got no response but when wired the ping goes through. So its defiantly something with the wireless signal…
  • Thanks

The SSID on the router and bridge must match exactly.:smiley: I have been able to contact the Crio over wireless from my laptop, I wouldn’t do any updates over wireless, but was able to ping it through wireless.

Even when my laptop is connected over ethernet, the system has similar connection issues.

A couple of teams reported slow/laggy wireless control until they reset the wireless router to use the 802.11n frequencies only. Don’t try to use your laptop wirelessly; plug it directly into the router or the second port on the Driver Station.

802.11b/g mixed mode probably has a longer setup time then just 802.11n only. I am going to switch to 802.11n only. thanks Alan

did you try plugging it in lol

I bet it takes the cRio + DS longer to startup than the routers. Even in b/g/n modes.