WPI installer and Lubuntu 22.04 - no usable version of libssl found

title line says it all; trying to install WPIlib 2022.4.1 on a fresh Lubuntu system.

user@sony-vaio-linux:~/Downloads/WPILib_Linux-2022.4.1$ ./WPILibInstaller 
No usable version of libssl was found
Aborted (core dumped)

I will put an issue into github, but was wondering if anyone else has conquered this.

What I have found for solutions (install old version of libssl) does not seem to be a possible solution (cannot find old SSL packages).

1 Like

sudo apt-get install libssl1.0.2 doesn’t work? What about sudo apt install libssl-dev?

libssl1.0.2 does not seem to be in Lubuntu 22.04. Didn’t see it in synaptic, and apt:

sudo apt-get install libssl1.0.2
[sudo] password for user: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
E: Unable to locate package libssl1.0.2
E: Couldn't find any package by glob 'libssl1.0.2'
E: Couldn't find any package by regex 'libssl1.0.2'

I did an strace on the installer, looks like the .net runtime is looking specifically for libssl1.0 or 1.1.

I ended up building 1.1.1m from source and installing it. That worked, just took a few minutes.

3 Likes

I’m pretty sure this is due to the WPILib Installer still using .NET 5. We had planned to move to .NET 6 (which I think uses openssl 3.x instead of 1.x), but couldn’t do so for the 2022 season, as we didn’t want to drop Windows 7 support until the 2023 season (.NET 6 doesn’t support Windows 7).

1 Like

I worked through the libssl issue described above using the link that fovea1959 posted.

Now I am get the following:
The SSL Connection could not be established. The remote certificate is invalid because of errors in the certificate chain: UntrustedRoot.

Has anyone else seen this error? It occurs at that point in the installer where I select the upper left box “Download for this computer only (fastest)”.

Should I be selecting one of the other boxes for a Lbuntu 22.04 install?

Thank you.

-Tom

Just wanted to update this thread with a solution (worked for me at least). I am running Linux Mint (aka “ubuntu 22.04”)
the steps are:

  1. do all of this: https://linuxpip.org/install-openssl-linux/
  2. make your ssl certs visible to the version installed in step (1):
    cd /usr/local/ssl; sudo mv certs certs.not; sudo ln -s /etc/ssl/certs

should work after that.

This is because the root certs are not installed with the “bespoke” 1.1.1m openssl build, and it needs to use the root certs that were installed with the OS.

Thank you for the pointer with openssl install. It now works as expected and I can install the WPI installer just fine.

Trying things from my bootable usb stick with Lubuntu 22.04, I can run VSCode just fine. However, when I try to run the Pathweaver tool I can’t create a project. SysId doesn’t seem to allow parameter inputs when that opens up. Do the various tools under the Start Tool option work under Linux?

Thanks for your help!

Can you share the result of python --version?

python3 --version

Python 3.10.4

The tools do run under Linux, but as the ssl things can be issues for the Java version we use as well, we can’t guarantee things will work in 22.04. We will make sure everything for 2023 works in 22.04, but for 2022 stuff we only guarantee support on 20.04