WPILib simulation not working for me on MacOS 12.3

I’m setting up WPILib on a Mac I recently got, Intel based running MacOS 12.3.1, and having several issues that I didn’t have on Windows.

I expect I’m doing something wrong but can’t for the life of me figure out what?

I have tried this with WPILib 2022.4.1 and 2022.1.1 and 2021.1.1, all consistently having these two problems:

  1. The .dmg installer puts a VScode.app into ~/wpilib/2022/vscode. But when I run that VSCode it doesn’t have the WPILib extensions. I can install them from within VSCode and then they show up - but from the .dmg installer consistently they don’t.

  2. Once I manually install the WPILib extensions as in #1 above, I can run WPILib Create New Project and create one of the Simulation projects. But then when I run the WPLib Simulate command it gives a “no registered deployers” error.

I suspect that these are related - because my original install didn’t configure VSCode correctly, I manually did part of the process but not all of this.

Two questions therefore, does anyone know either:
a) how I can get my .dmg installer to properly configure VScode on MacOS 12.3.1/Intel?,
or
b) how I can manually configure to avoid the “no registered deployers” error?

edit1: I tried in macOS Catalina 10.15 (in a Parallels VM) and the .dmg installed correctly. It seems to be either a Monterey 12.3 specific issue or else something particular to my machine.

edit2: I have a solution in my own situation, based on this: WPILib Installation issue on macOS 12.1 - #10 by ohowe. What I had to do was:

  1. Go to VSCode extensions (left bottom Tetris icon), then three dots, then Install from VSIX.
  2. Find the extensions files - for me they were at ~/wpilib/2022/vsCodeExtensions, and included five .vsix files.
  3. Install from VSIX for each of the five.
  4. Restart VSCode.

After doing that then my simulation executed.

2 Likes

Update: pretty sure this is an issue with the installer. I opened https://github.com/wpilibsuite/WPILibInstaller-Avalonia/issues/262.

The workaround of manually installing extensions has been added to the WPILib known issues. Known Issues — FIRST Robotics Competition documentation

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.