WPILib Suite 2017

WPILib Suite 2017 has been released! There have been a number of significant changes to WPILib for the 2017 FRC season. Take a look at what is new this year: https://wpilib.screenstepslive.com/s/4485/m/13503/l/681378-new-for-2017

Teams can get started by downloading the 2017 release through Eclipse by following these instructions: https://wpilib.screenstepslive.com/s/4485/m/13503/l/599679-installing-eclipse-c-java

You will not be able to deploy to your roboRIO until you image it with image version 2017v8 which is included with the FRC Update Suite.

We have been working hard updating the ScreenSteps documentation. If you notice anything out of place, please submit a report by completing the form at the bottom of page with the issue.

WPILib for C++ and Java are now Open Source projects collectively called WPILib Suite and have moved to GitHub. You can view, download or clone any of the repositories in the WPILib Suite of repositories.

Woohoo!! This is fantastic news!

An important clarification: we have always been open source. You receive a full copy of the sources when you install WPILib. However, we used to be on CollabNet, and we moved to GitHub for easier team access.

I was wondering when the Linux ToolChains will available on the following site: http://first.wpi.edu/FRC/roborio/toolchains/

The windows ToolChains appear to already be available.

Also, can someone confirm which versions of Ubuntu have been tested?

Matt Ballard
Mentor Team 4329

We have moved away from the NIVision libraries in favor of OpenCV as a fully integrated solution.

The linux toolchain should be there now. Please check again. In the instructions link it lists the supported versions of Ubuntu.

Awesome, just installed the update.

I tried following the link to the CTRE libraries to get the CAN Talon library, and I get to the HERO CTRE Toolsuite download page, which claims it comes with the libraries for FRC, but I’ve DLed and installed it and the only thing it gives me is a tool for imaging the CTRE HERO board, and a CAN and Roborio configurator.

Are the CANTalon libraries just not posted yet, or am I missing something?

I used the Non-installer version which just has the libraries with instructions on where to place them. I would guess that the installer put the necessary files in your wpilib folder already. Go to C:/Users/you/wpilib/user/language/lib and check for the ctre library.
The updated wpilib is really nice because anything in that lib folder is automatically included in your eclipse robot projects.

Joey is correct.

The CAN Talon SRX Libraries are in the Installer - when you get to the component tree page of the installer you should see LabVIEW and C++/Java options. These contain all CTRE Libraries (outside of PCM/PDP).

The libraries are then installed in the background during the installation process - there’s nothing else you need to do to have them integrated with Eclipse. Just put the appropriate include or import statement in your code.

Just as a note, there will be a final pre-kickoff installer uploaded later tonight that has several updates. Don’t worry if you’ve already run the current installer - you can just run the new one and it will update everything appropriately.

Painless and easy, nice work folks!

Are there any plans for setting up a purely-release download that can be used for something like TravisCI? Last year my team relied on manually copy-pasting the Java distribution into a repo that the Travis script would clone. This felt dirty and I always felt guilty about it. Either something like another PPA or similar would be hugely helpful.

Is there something wrong with the Java plugin? I just tried updating and while it looks like I have the new version (2017.1.1) I don’t see any of the new features and none of the jar files have been touched. I tried uninstalling the plugin and deleting the files and then re-installing, but still no luck.

I was really hoping for a more standardized library installation method (eg maven) this year. With the separating of the libraries this seems to significantly complicate anything but a “standard” installation, which can be difficult on some school locked-down computers.

We support Maven as an alternative download method, this might be what you’re looking for. See the article here: http://wpilib.screenstepslive.com/s/4485/m/wpilib_source/l/480976.

We do support Maven! I’d suggest checking out GradleRIO, which probably does what you want. Find it here: https://github.com/Open-RIO/GradleRIO. Note, however, that this is just for the standard WPILib libraries. We don’t publish artifacts for 3rd party libraries.

As far as we’re aware, there are no issues with the plugin like that. What version of Eclipse are you using? If you delete the ~/wpilib folder and restart Eclipse, what happens? It should re-extract the wpilib binaries.

Tried that, no luck. Took a look in the plugins folder and found some older version jars. Deleted them and the wpilib folder, restarted and now I’m good. Thanks!

What is the difference between the 2016 C++ toolchain and the one for this year (2017)? I can’t seem to find a changelog, and they’re supposedly the same GCC version.

The installer itself had a few bugs fixed, and it has a new sysroot to match the 2017 image. The compiler version itself is the same.

Does anybody know where the API/Documentation is for the CTRE CANTalon library? It is not on the first wpilib documentation and I can’t find it anywhere on the CTRE site.

My team uses Java. Last year the CANTalon library used to be built in to the WPILib but now it is part of the 3rd party libraries from CTRE. I have gotten that setup on my development machine but I can’t find any documentation anywhere on classes in the library (javadoc).

http://wpilib.screenstepslive.com/s/4485/m/13503/l/682619-3rd-party-libraries should be of use. This page should be in a sticky somewhere, it’s crucial and really hard to find…

The repository that the page references doesn’t seem to have any 2017 releases yet? I’m not finding any reference to “athena” like the page says, though that could be unfamiliarity with the maven structure

EDIT: Never mind, found it