WPILib version 4.2 for C++ seems to have a camera problem

There seems to be a problem when using WPILib version 4.2 for C++ 4.2 with the Axis 206 camera. Here are the specifics:

We were originally using the WPILib 4.0 release for C++, but we were having trouble getting reliable performance when programming the Axis camera to look for the vision target in the images.

When WPILib 4.1 for C++ version was released on 2/3/2010, it was great, because it fixed all of our camera programming problems, and also provided support for the ADXL345 accelerometer in the 2010 Kit of Parts, which has been very useful for us as well. However, WPILib 4.1 prevented DriverStationLCD functions from working. More specifically, when using WPILib 4.1 and running NetConsole, we see a problem with a DriverStationLCD symbol:

Warning: module (t1) deleted: errno=1835009 (x1c0001) status=1
_ZN16DriverStationLCD11kLineLengthE.
(unloading partially loaded module FRC_UserProgram.out)
…FRC_UserProgram failed to load.

So then, WPILib 4.2 for C++ was released on 2/8/2010 to fix this problem with DriverStationLCD. And indeed, DriverStationLCD is fixed. But in WPILib 4.2 for C++, there is now a new problem with the camera. Whenever we use any of the Axis camera C++ functions with WPILib 4.2, the camera doesn’t work. When running NetConsole, we once again see a problem with an external symbol, but this time the problem symbol is in the camera code. That seems to be the source of the problem.

We would really like to use the camera. Is anyone else seeing this problem? Does anyone know if a new WPILib release will be coming out for WPILib 4.2 for C++ to fix the camera problem? Many thanks!

http://forums.usfirst.org/showpost.php?p=38358&postcount=4

This post [and the attachment] should fix your camera issues; it fixed all the camera problems we had with 2-08. (See: Unresolved symbols in AxisCamera no longer appear).

Good luck! ^^

Glad our workaround helped you out. For anyone having this issue with the 2-8 C++ update, please post followups on the above thread on the official forums to state that you had the problem (and if you try the workaround quoted above, please note too if the workaround did or did not fix it for you).

Heydowns: Will do. Going forward, I will continue this thread’s conversation about this issue on the equivalent thread over on the FIRST forums.

Thanks for posting, to that FIRST forum thread, a workaround for the AxisCamera problem with WPILib 4.2 for C++, much appreciated. But we also use the DriverStationLCD class, and Sunit pointed out in that thread that the workaround you posted brings back the unresolved symbol from DriverStationLCD. We use both AxisCamera and DriverStationLCD heavily, so it looks like we don’t have a solution yet that will work for our team.

In any case, I have posted the above info also to that FIRST Forum thread, so WPI will know that we are experiencing the same problem as other teams with the WPILib 4.2 release for C++, and we can continue the discussion over there.

Yikes, only 8 days to robot ship. I hope an official WPILib update for C++ gets released in the next day or two that resolves the AxisCamera unresolved symbol problem. I know the WPI team must be working hard on it, and we appreciate their efforts!

Try the second attachment I posted there (-v2.zip), if you want. It should hopefully fix both the camera and LCD issues.

We also hit problems with the camera and another team posted a link to a Lavview update that has Crio(v20). After updateing we tried first default camera code as well as what we had working before. Neither has worked out successfully. We also tried completly reimaging our classmate and reinstalling updates. Still no success. Seeing as other teams are haveing these issues im guessing it is an error in Firsts axisCamera libraries. If anyne hears about ny new updates or figures out how to make the current update work please keep us posted.

Team1111-Hoffman

This AxisCamera problem in WPILib 4.2 for C++ has been fixed. The new WPILib 4.3 release on 2/17/10 has resolved this AxisCamera unresolved symbol in our tests. The DriverStationLCD is still working correctly as well. Super thanks, WPI!