xRC v7.1 - New Bots added

Test game strategy now with realistic bots. Two new bots added:
-Bulldogs Ri3D + climb mechanism
-Altered “FRC Shooter” with climb mechanism

Download at https://xrcsimulator.org/Downloads

9 Likes

Our team, 3707 Brighton Techodogs is making good use of the simulator, thank you for the extra bots!

When I try to run the simulator, CPU and GPU peg at 100%. Any idea why?

Windows 10, Intel i5, 16GB RAM, NVIDIA GeForce GTX 960M. I mean, it’s an older laptop, but runs other games without issue.

The graphics default to the “beautiful” setting, and the only way to change it is to open it. It would be nice if it defaulted to fastest so it works better.
However, the CPU at 100% doesn’t make sense.

I would recommend looking at the graphics setting as Berkeli mentioned, and if that does not fix it, feel free to join the xRC Sim Discord at https://secondrobotics.org/discord. We’ll be able to offer support and more easily pass back and forth screenshots.

1 Like

I found that I needed to run the game at 1920×1080 instead of 3840×2160 on my 5-year-old computer to get acceptable performance.

1 Like

Outside of setting quality to “fastest”, maybe reducing resolution, etc… the game normally tries to run at the fastest frame-rate it can (greedy algorithm), but there is a max frame rate setting. The default I think is 60 Hz, you may want to reduce that to 30 Hz for a laptop.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.