yes comunication, yes code but no response by robot

the driver station shows that we have communication and that we have code on the CRIO and that we have input from the joysticks. When we push the controls on the joysticks nothing happens. please help and by the way we were able to connect and run stuff directly after the competition but not wirelessly.why?

You did enable the robot on the Driver Station correct?

Assuming your using the older gaming adapter:
You need to disable the encryption on the wireless gaming adapter. At a competition it gets set up with a special networking key, that needs to be removed. This can be done by directing your browser to 10.xx.yy.1. The user-name and password are “admin” Then go to basic, then wireless. Then at the bottom you should see a section labeled encryption or something similar. There should be an option to disable it. Once that’s done, hit save settings and restart now. Then you should be able to connect via wireless.

There’s a bunch of things to check here.
Is the robot enabled?
Are the motor controllers hooked up correctly? (Is the PWM cable plugged in the right way on the controller? On the digital sidecar? Are they in the correct ports?)
Are the motors hooked up correctly?

Has anything changed since the last time the robot ran?

every thing here has been done

i have physically reset the gaming adapter, but not have done anything about encyption i will try it and get back to you.

Look in the Diagnostics tab of the Driver Station and check if there are any errors listed in the text box

What do you mean by “physically reset the gaming adapter”? If you reset it to factory default, you will need to go through the entire configuration process in the control system manual.

I pressed the reset button on the back of the gaming adapter

Yeah, then you’re going to have to reconfigure it manually. The good news is that resetting it gets rid of the competition encryption setting.

Follow the instructions from the Control System manual #2 on configuring the gaming adapter (setting the IP address, changing some settings, etc.)

Just wondering, since it isn’t clear yet: Do you have the old robot radio/gaming adapter that looks like a black, square box? Because there is a new one that some rookies used and that would change the process a little bit…

I reconfigured it manually and i can connect wirelessly now(which is what i originally wanted), but we now realize that our robot does not work. Is there a way to tell if the CRIO is outputting our code to the digital sidecar or if it is the digital sidecar that does not work. we have tried to test the sidecar with a multimeter and it does not give out signal.

Look at the three green power LEDs on the Digital Sidecar. Also pay attention to the Robot Signal Light. Tell us what you see.

The RSL is intended to give an indication of what the cRIO is doing. If your big orange flashy light isn’t doing anything, look at the little green flashy light on the digital sidecar where the big light is supposed to connect.

A general suggestion: when you describe what you’ve been doing, please give a little more detail. For example, saying “every thing here has been done” is not the best response to a list of questions, especially if the final question was whether you had changed something since the last time things worked. We also don’t know exactly what you mean when you say “test the sidecar with a multimeter.” Being more specific will help us to help you.

The 3 indicator lights on the digital sidecar are all in indicating that the sidecar is receiving power. As described, the small green blinky light does not seem to flash anymore as it did in competition. The light subsequently does not seem to be receiving the signal to turn on and off.

This either means there is a problem with your DB37 cable, or there is a problem with the image on the cRIO, or that the LED is burnt out.
The light should always be flashing or on.
Your orange light (Robot Signal Light) should be plugged into the two pins by this flashing LED on the Digital Sidecar. What is it doing? If it is flashing or solid on, then your little green LED is burnt out.

You can measure resistance with a meter to determine if the cable is at fault. The Robot Signal Light is multiplexed off the serial Relay Output data. You want to check pins 18, 19, 20, and 21.

If the cable turns out good, then try re-imaging your cRIO, and deploy the default code to test.

…or the DIO module is faulty, or not plugged in, or plugged in to the wrong slot…or the DB15 connector in Slot 4 of the cRIO is broken, or shorted by debris, or not making contact properly because of a foreign object…or the cRIO is broken…

At this point, it would probably be easiest to start swapping out components until you find one that makes things work.

The little green LED will still flash regardless of whether the DIO module has 12v power or not. It will simply flash much dimmer without the external power.
Just swapping out components is a good way to break things. (The Digital Sidecar supposedly has reverse-voltage protection, but who knows if it was implemented?)

However, you are correct I was making assumptions about the functionality of other parts. A good test for the digital sidecar would be to to use a digital input or output. (If you want to test the motor controllers that way, a 1.75ms pulse should be about 50% full speed)

We have swapped out the modules already and tested different cables and sidecars and tested the voltage on each sidecar and it is getting power but not a signal.

When you say module you are referring to the Digital Sidecar correct?
If so, then the problem seems to be with your Crio. If you have a different digital module you should try swapping that in.

Is the analog module properly installed with the jumper? If so, is the battery voltage showing on the classmate?

What happens if the Digital module is moved to the other slot (slot 6 I think) and your code is updated to output to that slot?

Did you try a different cRIO?

Look closely at the DB15 connector for Slot 4. Make sure none of the pins are broken or bent. Use a good strong light to check for debris between the pins.

You’re still being a bit vague in your descriptions of what you did. How have you “tested the voltage on each sidecar”? Which points did you measure? What do you see that indicates to you that it’s not getting a signal?

We do not have a different CRIO but i re imaged it and now when i try to upload code to the CRIO i get the error from windriver saying that It failed to launch to target server and that it could possilbly be caused by back end not connected and idk how to read this or what it means.