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Goal of Workshop

• Demonstrate a process to create a basic Robot using Eclipse and RobotBuilder

WPI (Worcester Polytechnic Institute) Robot Builder Resource:

• https://wpilib.screenstepslive.com/s/4485/m/26402



Process to Build Robot Software - Overview
1. Design the Robot on Paper

2. Build Robot in RobotBuilder
• Create subsystems, commands and Operator Interface

3. Import RobotBuilder into Eclipse

4. Finish the Software in Eclipse 
• Create methods within the subsystems to implement commands

5. Deploy, Test, Troubleshoot

6. Expand, Revise, Enhance



Development Environment

• Hardware
• Practice Board (RoboRio, Power system, motors, servos, pneumatics …)

• Software
• Eclipse – Luna with WIPlib Extensions

• JAVA – SDK (Software Development Kit)

• FIRST Drivers Station

• Network
• Basic for demonstration



RoboRio Practice Board



Step 1: Design the Robot

Understand the Game then Design the Robot
• Define the Requirements for the Robot

• Understand how to play the Game and scoring

• Decide how your Team will play the game

• Decide what your robot needs to do

• Create an initial design of the Robot
• Drive Train, Shooter/Manipulator, Drivers Station, automation

• Decompose the Robot into Subsystems
• Identify Subsystems and the User Interface

• Software High Level Design
• Determine what functions/actions the subsystems must do

• Determine the best approach for the User Interface



Design the Robot
Given high level design of subsystems and functional requirements

• Software Detailed Design
• Document the functions to be performed

• Document the User Interface 

• Joystick / Gamepad / Buttons, Camera displays

• On-Robot indicators

• Determine where automation can assist

• Determine what sensors are needed 

• Create commands to drive the subsystems

• Link in the User Interface

• Create methods for the subsystems



Design the Robot – Drive Train
Drive Train Options:

• Tank drive   vs. Mecanum  vs.  Swerve drive

Items to consider for each option:

• Complexity,    Robot agility,     Time to build,    Weight

• User Interface

• Tank Drive, Arcade Drive

• JoyStick, Gamepad

• Display of first person video

• Software

• Capabilities during Autonomous   (Drive straight for an exact distance, turn precisely, …)

• Sensors:

• Gyro, Accelerometer, Shaft Encoders



Design the Robot - Shooter/Manipulator Subsystem

Shooter/Manipulator Subsystem:
• Ball Launcher, Arm/claw, Kicker, Climber

Types of forces & movements:
• Linear movement –Motor/chain/track, pneumatics
• Rotational movement – Motors / gears 

For every automated action/motion, a feedback sensor is required

• Types of Feedback Sensors:
• Limit / position switch, Gyro, Accelerometer, potentiometer,  shaft encoders, 

Range finders, camera





Design the Robot - Sensors

For every automated action/motion, a feedback sensor is required

For example, to have the robot turn 90 degrees, your can’t rely on turn 
rate over for a fixed amount of time.  Need to use a Gyro!

Why?  (Battery voltage fades, wheels slip, …)

For every automated action/motion, a feedback sensor is required



Design the Robot - Sensors for Feedback

Sensor Usage

Limit / position switches End of travel for arm, elevator, kicker, …

Gyro Heading to assist in autonomously driving a straight line

Accelerometer Tilt of robot

Potentiometer Rotational Angle

Shaft encoders Rotations of a shaft (translating into height elevator)

Range finders Distance to wall

Camera Target tracking, Assist driver with aligning 

For every automated action/motion, a feedback sensor is required



Software Design

Think about what to include in the subsystems

Drivetrain should include the sensors to measure distance, heading and 
range to target

This allows high level commands to be given to the subsystem

• For example, Move forward 2 feet, turn 90 degrees

Object Oriented Design:
Details of the Object implementation are kept within the subsystem



Software Design – Subsystem Requirements

DriveTrain:

• Requirements:
• Move forward, backward, and rotate

• Maximum forward speed: 2 feet/Second (Fast)

• Simple to build, light weight

• Drive in a straight line in autonomous mode

• Can stop at specified distance to wall

• Can turn 90 degrees on command

• Can move forward 4 feet on command

• Drive with single joystick

• Implementation:
• Tank Drive : 4 Motors

• Sensors: Shaft Encoder, Gyro and Range finder



Software Design – Subsystem Requirements

Manipulator / Arm:

• Requirements:
• Move left and right, slow and precise

• Move to any position with buttons

• Move to center position with button

• Implementation:
• Strong slow Motor 

• CAN bus controller

• Sensor that provides feedback: Potentiometer



Software Design
Document each subsystem methods and commands

• Subsystems
• Drive Train – 4 motor 

• Commands: 
• Stop, manual drive with joystick 

• Drive forward until 5 feet from wall

• Turn Right 90 degrees, Turn Left 90 degrees

• Move forward x feet

• Arm/Manipulator
• Commands:

• Stop, manual drive with left and right buttons

• Move to setpoint

• Operator Interface
• Single Joystick: X and Y axis

• 3 Buttons:  Move arm left, Move arm to Center, Move arm to right



Software Development
Setup



Software Development Setup
One Time Configuration of Eclipse

• Initial Configurations (One Time)

• Set Team Number
• Eclipse => Windows => Preferences => WPI Lib Preferences  = Team Number

• Configure Eclipse to sync with RobotBuilder  
• Updates in RobotBuilder are automatically added to the Eclipse Project
• Eclipse => Windows => Preferences => General => Workspace = Enable Refresh using Native hooks or Polling

• Display Console Window
• Eclipse => Window => Show View => Other ... => General => RioLog

• Create Workspace in Eclipse to hold Robot Project
• Eclipse => File => New => Project… => WPILib Robot Java Development => Example Robot Java Project

=> Getting Started with Java => Getting Started => Finish

Resource:

https://wpilib.screenstepslive.com/s/4485

Detailed Process:

https://wpilib.screenstepslive.com/s/4485/m/13809/l/145307-creating-your-benchtop-test-program



Step 2: Build Robot in RobotBuilder
Start and Initialize RobotBuilder Project

• Eclipse => WIPLib => Run RobotBuilder

• On Creation of new Robot Project, set:
• Project Name:     e.g.:  RobotOne
• Team Number: e.g.: 1895

• In Robot Project, set:
• Java Package: e.g.:  “Team1895.RobotOne”
• Eclipse Workspace: e.g.: “C:\_Robotics\2016\Eclipse_Projects”

• See current workspace:   Eclipse => File => Switch Workspace => Other
• Wiring File: e.g.: “C:\_Robotics\2016\Eclipse_Projects\RobotOneWires”

• Save the RobotBuilder Project file
• Select  RobotBuilder => Save As => “C:\_Robotics\2016\Eclipse_Projects\RobotOne”

A package is a namespace 
that organizes a set of related 

classes and interfaces. 
Conceptually you can think of 
packages as being similar to 

different folders on your 
computer.



Robot Builder – First startup



Build Robot in RobotBuilder

• Create
• Subsystems

• Commands for subsystems

• Operator Interface
• Add a JoyStick

• Add a Button on the JoyStick

• Associate Buttons with Commands



Software Design (Reminder from the design phase)

Document each subsystem methods and commands

• Subsystems
• Drive Train – 4 motor 

• Commands: 
• Stop, manual drive with joystick 

• Drive forward until 5 feet from wall

• Turn Right 90 degrees, Turn Left 90 degrees

• Arm/Manipulator
• Commands:

• Stop, manual drive with left and right buttons

• Move to setpoint

• Operator Interface
• Single Joystick to drive the robot using  the X and Y axis

• 3 Buttons:  Move arm left, Move arm to Center, Move arm to right



Adding Subsystem and Commands to the 
Robot in RobotBuilder

Two methods to add elements

•Drop and Drag

•Right-click and select



Add subsystems, Joysticks, and sensors by right clicking and selecting







Robot Builder – Explorer and Wiring Diagram



Step 3: Import RobotBuilder into Eclipse

• Save the RobotBuilder Project
• Select  RobotBuilder => Save As => “C:\_Robotics\2016\Eclipse_Projects\RobotOne”

• Export the Java Code
• Select  RobotBuilder => Export => Java       Or   “Java” on the Menu

• Import the Java Project into Eclipse
• Select Eclipse => File => Import => General => Existing Projects into Workspace

• Browse to project folder:   e.g.:  “C:\_Robotics\2016\Eclipse_Projects\RobotOne”



RobotBuilder Project Resulting JAVA Project

Robot Overhead





Step 4: Finish the Software in Eclipse
Detailed Coding Begins ………. 

At this point you have a lot of code that does nothing!

Need to tie inputs to outputs using methods

Need to create Methods() within the Subsystems

Commands call Methods ()

User Interface calls Commands

A “Command” object Tells a “Subsystem” object to do something by way of “Methods”



Enter the FRC IterativeRobot Class

RobotBuilder creates an framework or template based on the IterativeRobot

Supports: 

• Robot software initialization

• Autonomous mode

• TeleOperate mode

During development, the operating mode is selected by the DriversStation

During Competition, the mode is controlled by the Field Management System



High level structure of the IterativeRobot
Power On
Runs robotInit() method 

Initializes all of the defined subsystems (Runs constructors)

Runs OI() method
Initializes the Operator Interface (Runs constructors)

Runs disabledInit() method once
Runs disabledPeriodic() method REPEATEDLY

Runs autonomousInit() method once
autonomousPeriodic() method REPEATEDLY

teleopInit() method once
teleopPeriodic() method REPEATEDLY

15 Seconds

2 Minutes

Waiting for Go



• Checks for Operator Interface actions

• Links the commands to be run

• Calls the methods in the subsystem  
and runs one time
• Gets input
• Processes
• Sets output

teleopPeriodic() method 

• Code run in continuous loop for 
autonomousPeriodic() or teleopPeriodic()

• Loop is call 50 times per second (Wow!)



Simple Example of a Control Flow

• JoyStick button initiates a command

• Command calls a subsystem method

• Subsystem method takes action



Simple Example – Operator Interface Calls the Command

When Button 2 is 
pushed, the command 
to Move the Arm is run



Commands call 
Subsystem Methods

Simple Example – Commands Calls the Subsystem Method



Methods Control 
the hardware with 

primitive 
commands

.Set(0.5)     [Mid point]

.set(1.0) 
[Full clockwise]

.Set(0.0) 
[Full Counter

Clockwise]

Simple Example –Subsystem Method controls Hardware



Another Example:
Add Methods – Release a ball held by a Trigger

• Pull the Trigger and release the Ball

• Create a method called ReleaseBall()

• When called:

• Start motor turning clockwise at 25% speed

• Stop the motor when switch 2 closes

• Reverse motor, turn counter-clockwise at 25%

• Stop the motor when switch 1 closes
Switch 2

Switch 1



The Operator Interface
Calls Commands

The Commands
Calls Methods within 
the Subsystems

Pull a trigger

Fire the Ball

ReleaseBall()

Robot Top file

Commands

Subsystems

Operator Interface



OI calls a command

Trigger calls the 
Command



Update Commands 
with subsystem 

Methods



Methods to Release a ball held by a Trigger
Command call 

Methods



Options for Commands

The Command based approach provides a
great deal of flexibility

When a command is called you can call methods:

• Call a subsystem method one time at the beginning

• Repeatedly 

• Call a subsystem method one time at the end of a command



public class  Arm_MovetoCenter extends Command {

public Arm_MovetoCenter() {

requires(Robot.arm);

}

// Called just before this Command runs the first time

protected void initialize() {

}

// Called repeatedly when this Command is scheduled to run

protected void execute() {

}

// Make this return true when this Command no longer needs to run execute()

protected boolean isFinished() {

return false;

}

// Called once after isFinished returns true

protected void end() {

}

// Called when another command which requires one or more of the same

// subsystems is scheduled to run

protected void interrupted() {

}

}

Options for Commands



Default Command

• The command performed when no other commands are given to a subsystem

• Each subsystem may, but is not required to, have a default command which is 
scheduled whenever the subsystem is idle 

• The most common example of a default command is a command for the 
drivetrain that implements the normal joystick control.



Default Command



Autonomous Command

Create an Autonomous Command Group

• Tells the Robot what to do when in Autonomous Mode

• Consists of a sequence of other command 

• Performed in series or parallel

Start of 
Autonomous

Move Forward
4 feet

Turn Right 90 
degrees

Raise Arm

Move to 
exactly 6 feet 
from Target

Shoot Ball

Notice how these actions 
are performed in parallel



Go!

• Compile => Deploy => Execute

Screen Capture of Eclipse
Start Dashboard
Enable Smartdashboard
Compile and Download
Enable and test



Compile and Deploy



Console Display of Successful Deployment



Smart Dashboard



Start the Smart Dashboard



Initial Checkout!

• Lift Robot wheels off of ground to prevent sudden unplanned movement

• Keep hands, fingers and hair away from Robot

• Test one function at a time

• Observe and think

• Take Notes



Updating the Code to Solve Problems

Code update can be performed either in Eclipse or RobotBuilder

• In Eclipse, edit code directly.     Always add comments

In RobotBuilder:

• Re-Open RobotBuilder, Make the required updates, then export

• In Eclipse, Refresh the project by selecting “F5”

• The robotBuilder updates will be shown, User provided code remains

Don’t edit code between the 
RobotBuilder comments



Step 5: Test, Troubleshoot, Resolve
Iterative Process…

Test

TroubleshootResolve



Troubleshooting Methods:

1)   Print statements to the System Console (Riolog)

System.out.println("Ball Release Going Out");

2) Smart Dashboard

3) Many other approaches …

Console



?



Manassas, VA
Osbourn High school



Resources
Guidance

https://wpilib.screenstepslive.com/s/4485

WPI Library

http://first.wpi.edu/FRC/roborio/stable/docs/java

http://first.wpi.edu/FRC/roborio/stable/docs/java/classedu_1_1wpi_1_1first_1_1wpilibj_1_1command_1_1WaitCommand.html

Eclipse:

http://help.eclipse.org/luna/index.jsp?topic=%2Forg.eclipse.cdt.doc.user%2Ftasks%2Fcdt_t_comment_out.htm

FRC Roborio eclipse plugins zip file

http://first.wpi.edu/FRC/roborio/zipfile/

WPI ThinkTank

http://thinktank.wpi.edu/Portal

https://wpilib.screenstepslive.com/s/4485
http://first.wpi.edu/FRC/roborio/stable/docs/java/classedu_1_1wpi_1_1first_1_1wpilibj_1_1command_1_1WaitCommand.html
http://help.eclipse.org/luna/index.jsp?topic=/org.eclipse.cdt.doc.user/tasks/cdt_t_comment_out.htm
http://first.wpi.edu/FRC/roborio/zipfile/
http://thinktank.wpi.edu/Portal


Eclipse Issues

• Unable to find a javac compiler; com.sun.tools.javac.Main is not on 
the classpath. Perhaps JAVA_HOME does not point to the JDK.

• For eclipse 

• Right Click build.xml ---> Build path ---> configure buildpath ---> select libraries tab

• click "Add library" ---> double click on [jre system library ] ---> environments ---> installed jres ---> Add ---> standard 
vm

• click on directory ---> Browse upto jdk [C:\Program Files\Java\jdk1.7.0_01]

• finish

• change the selection jre to jdk ---> click ok

• Import Errors
• Eclipse => Source => Organize Imports

• Download errors due to Network Name Resolution
• Right Click “Build.xml”, 



Set the "JAVA_HOME“ Environment Variable

Instructions
1. Click "start“ 
2. Right click "computer“
3. Click "properties“
4. Click "advanced system settings“
5. Click "environment variables“
6. If "JAVA_HOME" is in the system variables then go to verify  else click "new"

"variable name" = "JAVA_HOME"
"variable value" = the location of your Java JDK it is close to "C:\Program Files\Java\jdk1.8.0_25“

7. Click "ok"

Verify
1. Open a command window and enter: set | find "JAVA_HOME"
2. Should display something like "C:\Program Files\Java\jdk1.8.0_25“
3. In the command Window, enter:  dir "C:\Program Files\Java\jdk1.8.0_25”
4. Should display the contents of the JAVA folder



Eclipse Networking Issues

• Download errors due to Network Name Resolution
• Right Click “Build.xml”, 



Terminology
Motor = Creates continuous rotational motion.  

Speed of rotation controlled by a PWM interface 
value of +1 to -1

Servo = Creates a limited rotational motion
Angle of output limited to +/- 100 degrees

Angle controlled by a PWM interface value of 0 to 1

LED = Light Emitting Diode – Lights up when voltage applied

Limit Switch =  Provides an electrical connection when lever arm depressed. 


